Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124140 - Ignore does not work peoperly if .hgignore file contains comments or sntax chnage
Ignore does not work peoperly if .hgignore file contains comments or sntax ch...
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 123874 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 16:02 UTC by Padraig Obriain
Modified: 2008-01-03 09:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (5.03 KB, patch)
2007-12-19 12:16 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Padraig Obriain 2007-12-17 16:02:53 UTC
If .hgignore file contains comments or statements of the form "syntax: glob" or "syntax: regexp then Ignoring or
Unignoring a file will corrupt the .hgignore file
Comment 1 Padraig Obriain 2007-12-17 16:05:01 UTC
If the .hgignore file contains "syntax: glob" or "syntax: regexp" then Ignore or Unignore will display a warning and not
attempt to ignore or unignore the file.

Comments in the file will be discarded when the file is updated.
Comment 2 Padraig Obriain 2007-12-19 12:16:46 UTC
Created attachment 54395 [details]
proposed patch
Comment 3 Padraig Obriain 2007-12-19 12:21:02 UTC
This patch also includes the patch for #123874.
Comment 4 Padraig Obriain 2007-12-19 12:23:32 UTC
IDE:-------------------------------------------------
IDE: [12/19/07 12:22 PM] Committing "Mercurial" started
Checking in HgUtils.java;
/shared/data/ccvs/repository/versioncontrol/mercurial/src/org/netbeans/modules/mercurial/util/HgUtils.java,v  <-- 
HgUtils.java
new revision: 1.25; previous revision: 1.24
done
Checking in Bundle.properties;
/shared/data/ccvs/repository/versioncontrol/mercurial/src/org/netbeans/modules/mercurial/util/Bundle.properties,v  <-- 
Bundle.properties
new revision: 1.19; previous revision: 1.18
done
IDE: [12/19/07 12:22 PM] Committing "Mercurial" finished
Comment 5 Padraig Obriain 2007-12-19 12:24:36 UTC
*** Issue 123874 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo