Bug 124016 - Dialog-box after creating a new Grails-project
Dialog-box after creating a new Grails-project
Status: VERIFIED FIXED
Product: groovy
Classification: Unclassified
Component: Grails
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: martin_adamek
issues@groovy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 10:21 UTC by schmidtm
Modified: 2008-10-30 14:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
create new project execption (7.04 KB, text/plain)
2008-01-14 16:41 UTC, schmidtm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schmidtm 2007-12-14 10:21:07 UTC
Right after creating a new grails project i get a dialog-box saying:

ALL [null]: might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using mapped drive
letters.

This is the console stacktrace:

        at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:210)
        at org.netbeans.api.java.classpath.ClassPath$Entry.getRoot(ClassPath.java:604)
        at org.netbeans.api.java.classpath.ClassPath.createRoots(ClassPath.java:272)
        at org.netbeans.api.java.classpath.ClassPath.getRoots(ClassPath.java:253)
        at org.netbeans.api.java.classpath.ClassPath.findOwnerRoot(ClassPath.java:439)
        at org.netbeans.modules.java.source.tasklist.TaskCache.isInError(TaskCache.java:336)
        at org.netbeans.modules.java.source.tasklist.ErrorAnnotator$1.run(ErrorAnnotator.java:289)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 schmidtm 2007-12-14 11:22:29 UTC
Simply created a new project on an path without spaces proved that this one is a duplicate of # 46813.

*** This issue has been marked as a duplicate of 46813 ***
Comment 2 schmidtm 2008-01-11 15:32:45 UTC
This issue is still open. It might be related to this one:

java.net.URISyntaxException: Illegal character in path at index 36: file:/Applications/NetBeans/NetBeans 6.0 Dev
200711041200.app/Contents/Resources/NetBeans/enterprise4/docs/jstl11-doc.zip

http://www.netbeans.org/issues/show_bug.cgi?id=121513

When we create a new Grails project on a path with a space i get this exception:

SEVERE [global]
msg
Caused: java.lang.IllegalArgumentException: Illegal character in path at index 18: file:/C:/Documents and
Settings/schmidtm/My Documents/data/TestOnWin/grails-app/controllers/ [file:/C:/Documents and Settings/schmidtm/My
Documents/data/TestOnWin/grails-app/controllers/]
[catch] at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:78)
        at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:210)
        at org.openide.filesystems.FileUtil.isArchiveFile(FileUtil.java:1554)
        at org.netbeans.spi.java.classpath.support.ClassPathSupport.createResource(ClassPathSupport.java:80)
        at
org.netbeans.modules.groovy.grailsproject.classpath.SourcePathImplementation.getResources(SourcePathImplementation.java:86)
        at org.netbeans.api.java.classpath.ClassPath.entries(ClassPath.java:296)
        at org.netbeans.api.java.classpath.ClassPath.getRoots(ClassPath.java:247)
        at org.netbeans.api.java.classpath.ClassPath.findOwnerRoot(ClassPath.java:439)
        at org.netbeans.modules.java.source.tasklist.TaskCache.isInError(TaskCache.java:336)
        at org.netbeans.modules.java.source.tasklist.ErrorAnnotator$1.run(ErrorAnnotator.java:289)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
ALL [null]: might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using mapped drive
letters.
Comment 3 martin_adamek 2008-01-11 16:49:58 UTC
I'll check this.
Comment 4 schmidtm 2008-01-11 17:11:37 UTC
I hereby verify the existance of this issue under Mac OSX/PPC:

java.lang.IllegalArgumentException: Illegal character in path at index 25: file:/Users/schmidtm/User Guides and Information/CrashTest/grails-app/taglib/ 
[file:/Users/schmidtm/User Guides and Information/CrashTest/grails-app/taglib/]
	at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:78)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:210)
	at org.netbeans.api.java.classpath.ClassPath$Entry.getRoot(ClassPath.java:604)
	at org.netbeans.api.java.classpath.ClassPath.createRoots(ClassPath.java:272)
	at org.netbeans.api.java.classpath.ClassPath.getRoots(ClassPath.java:253)
	at org.netbeans.api.java.classpath.ClassPath.findOwnerRoot(ClassPath.java:439)
	at org.netbeans.modules.java.source.tasklist.TaskCache.isInError(TaskCache.java:336)
	at org.netbeans.modules.java.source.tasklist.ErrorAnnotator$1.run(ErrorAnnotator.java:289)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)

Comment 5 martin_adamek 2008-01-14 14:18:41 UTC
Hmm, I cannot reproduce this on Intel/Leopard OS X
Comment 6 schmidtm 2008-01-14 14:31:29 UTC
I've tested it under 10.4 with my old Dual G5 PowerPC. I have another user facing this on Windows. I'll doublecheck this
right now on Ubuntu Linux/AMD64
Comment 7 schmidtm 2008-01-14 16:41:55 UTC
Created attachment 55044 [details]
create new project execption
Comment 8 schmidtm 2008-01-14 16:47:55 UTC
OK, I've tested it under:

Linux baldur 2.6.17-10-generic #2 SMP Fri Oct 13 15:34:39 UTC 2006 x86_64 GNU/Linux
Ubuntu 6.10, Edgy Eft - released in October 2006

I don't get the DialogBox but still an entry in the ide.log which indicates that we have an issue. The problem here is
that i get a variant of the exception given in the attachment some ~600 times in the message log:

WARNING: externally created folder: /home/schmidtm/TestDir with some spaces
        at org.netbeans.modules.masterfs.filebasedfs.FileBasedFileSystem.findFileObject(FileBasedFileSystem.java:159)
        at org.netbeans.modules.masterfs.filebasedfs.FileBasedFileSystem.findFileObject(FileBasedFileSystem.java:137)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getParent(BaseFileObj.java:364)
        at org.openide.filesystems.FileUtil.isParentOf(FileUtil.java:1131)
        at org.netbeans.modules.groovy.grailsproject.classpath.ClassPathProviderImpl.getType(ClassPathProviderImpl.java:130)
        at
org.netbeans.modules.groovy.grailsproject.classpath.ClassPathProviderImpl.getSourcepath(ClassPathProviderImpl.java:217)
        at
org.netbeans.modules.groovy.grailsproject.classpath.ClassPathProviderImpl.findClassPath(ClassPathProviderImpl.java:255)
        at org.netbeans.modules.java.project.ProjectClassPathProvider.findClassPath(ProjectClassPathProvider.java:64)
        at org.netbeans.api.java.classpath.ClassPath.getClassPath(ClassPath.java:540)
        at org.netbeans.modules.java.source.tasklist.TaskCache.isInError(TaskCache.java:330)
        at org.netbeans.modules.java.source.tasklist.ErrorAnnotator$1.run(ErrorAnnotator.java:290)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)

Comment 9 martin_adamek 2008-01-14 19:12:45 UTC
I made one fix today:
http://scripting.netbeans.org/source/browse/scripting/groovy/grailsproject/src/org/netbeans/modules/groovy/grailsproject/ui/wizards/NewArtifactWizardI
terator.java?r1=1.6&r2=1.7
to resolve problems introduced by recent performance changes in filesystems. Read this:
http://www.netbeans.org/servlets/BrowseList?list=nbdev&by=thread&from=827178
http://www.netbeans.org/servlets/ReadMsg?list=nbdev&msgNo=40143
Plaease try to update sources and run it again, let's see if it helps.
Comment 10 martin_adamek 2008-01-16 07:30:06 UTC
So can I close this one now?
Comment 13 Lukas Jungmann 2008-10-03 14:28:12 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo