Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123729 - Hg view is complaning about missing hgk
Hg view is complaning about missing hgk
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 08:21 UTC by Peter Pis
Modified: 2008-01-18 09:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (1.36 KB, text/plain)
2007-12-10 18:10 UTC, John Rice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2007-12-10 08:21:06 UTC
Product Version: NetBeans IDE 6.0 (Build 200711261600)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Userdir: D:\ide\60daily\user3

From within the command line I am able to run "hgview" and "hg view" inside the hg repository. But running this command
from the IDE, there is error shown about the "hgk" can't be found in PATH.
Comment 1 John Rice 2007-12-10 09:50:44 UTC
Which version of Hg are you using?

To get hgk to work on Windows, you need to install the "unofficial batteries included" release:
http://qct.sourceforge.net/Mercurial-BI.html

and add <MercurialInstallDir>\scripts to your PATH [Control Panel> System> Advanced> Environment Variables: System
Variables - select Path and choose Edit

The problem is that even if Hg can pick up hgk we need to be able to explicitly check for it. We could automatically
look for it under a scripts dir on Windows.
Comment 2 John Rice 2007-12-10 09:56:04 UTC
Updated release notes:
http://wiki.netbeans.org/wiki/view/MercurialVersionControlReleaseNotes1_4_2
Comment 3 Peter Pis 2007-12-10 09:59:30 UTC
I am using TortoiseHg. Can't you check for existence of "hg view" or "hgview" respectively? 

http://tortoisehg.sourceforge.net/
Comment 4 John Rice 2007-12-10 10:08:53 UTC
We hadn't tested with TortoiseHg.

The problem is that we don't know if hg view will work until we try. It looks like TortoiseHg is also using the
batteries included release.

I'll see if we can check for Hgk.cmd under the <Hg Install Location>/scripts subdir on Windows in addition to looking
for it on the explicit path.
Comment 5 John Rice 2007-12-10 18:10:28 UTC
Created attachment 54106 [details]
Proposed patch
Comment 6 John Rice 2007-12-10 18:12:07 UTC
Patch checks on Windows for presence of Hgk under "scripts" subdir of dirs on Path, if other checks fail. Tested and
works fine with TortoiseHg on Windows.
Comment 7 John Rice 2007-12-11 22:17:16 UTC
IDE:-------------------------------------------------
IDE: [11/12/07 22:16] Committing started
Checking in ViewAction.java;
/cvs/versioncontrol/mercurial/src/org/netbeans/modules/mercurial/ui/view/ViewAction.java,v  <--  ViewAction.java
new revision: 1.9; previous revision: 1.8
done
IDE: [11/12/07 22:16] Committing finished
Comment 8 Peter Pis 2008-01-18 09:00:49 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo