Bug 123725 - ability to specify parameters for script executed in command line
ability to specify parameters for script executed in command line
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Andrew Korostelev
issues@php
: PLAN
: 122281 (view as bug list)
Depends on:
Blocks: 123481
  Show dependency treegraph
 
Reported: 2007-12-10 08:04 UTC by Andrew Korostelev
Modified: 2008-10-23 13:24 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Korostelev 2007-12-10 08:04:06 UTC
when user invokes 'run in command line', it should be possible to specify parameters for testing purposes.
Comment 1 Andrew Korostelev 2007-12-10 08:09:05 UTC
see also issue 123727
Comment 2 Andrew Korostelev 2007-12-10 19:05:40 UTC
In addition to parameters to executed php script, 
it should be also possible to specify php interpreter options (e.g. php configuration file).

May provide ui that will help user to select interpreter options.
Comment 3 Andrew Korostelev 2007-12-18 15:35:38 UTC
Will separate ui for specifying parameters for interpreter and for script.
Parameters for interpreter are tracked by issue 124202.

UI for setting parameters for the script is the same for running in command line and running on server,
but implementation for using them is different.
this issue tracks implementation for 'run in command line'.

server case is tracked by issue 123727
Comment 4 Alexei Mokeev 2008-01-24 15:51:30 UTC
*** Issue 122281 has been marked as a duplicate of this issue. ***
Comment 5 Andrew Korostelev 2008-01-28 15:21:50 UTC
will specify and store script execution parameters in file properties.
Comment 6 Mikhail Matveev 2008-10-23 13:23:42 UTC
It's now possible to specify such parameters.
Comment 7 Mikhail Matveev 2008-10-23 13:24:54 UTC
Marking as verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo