Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123704 - Reviewing an assign that you created in the past
Reviewing an assign that you created in the past
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Mapper
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Nikita Krjukov
issues@soa
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-09 18:33 UTC by davelane
Modified: 2008-07-10 15:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
project (12.58 KB, application/octet-stream)
2008-01-17 14:37 UTC, Sergey Lunegov
Details
The exception. (1.97 KB, text/plain)
2008-06-09 21:08 UTC, Nikita Krjukov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davelane 2007-12-09 18:33:27 UTC
Exception
http://statistics.netbeans.org/exceptions/detail.do?id=13752
means that: Reviewing an assign that you created in the past doesn't seem to work anymore. This is a pretty serious error.
Comment 1 Sergey Lunegov 2007-12-10 09:23:16 UTC
Please provide more exact steps how to reproduce the issue.
Please also attach the project you work with.
Comment 2 davelane 2007-12-10 19:46:52 UTC
Would it be ok if I sent a project to your email address? It has to much work stuff in there for me to attach it here.
Comment 3 Sergey Lunegov 2007-12-13 11:49:21 UTC
yes send it to my email
Comment 4 davelane 2008-01-09 10:09:37 UTC
I sent you the code in decemeber. Can you confirm if you received it and / or if this is a bug?
Comment 5 Andrei Chistiakov 2008-01-17 11:10:38 UTC
Changed target milestone from Sierra to 6.1 in order to display correct info on
NB 6.1 dashboard
Comment 6 Sergey Lunegov 2008-01-17 14:37:55 UTC
Created attachment 55203 [details]
project
Comment 7 Sergey Lunegov 2008-01-17 15:10:23 UTC
David, I received the project. This is a bug. Exception is another but it exists.
We'll address it.

Nikita, I've attached the project.
Comment 8 Sergey Lunegov 2008-04-25 07:33:49 UTC
Will be addressed after Sierra
Comment 9 Sergey Lunegov 2008-05-22 11:28:11 UTC
Dave, looks like fixed in NB 6.1 FCS. Would you please verify.
Comment 10 pslechta 2008-05-28 14:12:46 UTC
QA, please verify this fix till 09-Jun-2008, so it can be part of NB 6.1 patch 2.
Also clarify if the bug fix is already part of NB 6.1 FCS or not.
Thanks!
Comment 11 Andrei Chistiakov 2008-05-29 12:25:49 UTC
NetBeans IDE Dev (Build 200805280004)

- open the attached project;
- open BPEL document;
- double-click topmost Assign activity on the diagram.

java.lang.NullPointerException
	at java.util.ArrayList.addAll(ArrayList.java:472)
	at org.netbeans.modules.bpel.mapper.tree.models.VariableTreeModel.getChildren(VariableTreeModel.java:181)
	at org.netbeans.modules.bpel.mapper.tree.models.EmptyTreeModel.getChildren(EmptyTreeModel.java:56)
	at org.netbeans.modules.bpel.mapper.tree.MapperSwingTreeModel.getChildren(MapperSwingTreeModel.java:288)
	at org.netbeans.modules.bpel.mapper.tree.MapperSwingTreeModel.isLeaf(MapperSwingTreeModel.java:110)
	at org.netbeans.modules.bpel.mapper.model.BpelMapperModel.isLeaf(BpelMapperModel.java:614)
	at org.netbeans.modules.soa.mappercore.MapperNode.updateNode(MapperNode.java:242)
	at org.netbeans.modules.soa.mappercore.MapperNode.<init>(MapperNode.java:82)
	at org.netbeans.modules.soa.mappercore.MapperNode.updateChildren(MapperNode.java:353)
	at org.netbeans.modules.soa.mappercore.MapperNode.loadChildren(MapperNode.java:234)
	at org.netbeans.modules.soa.mappercore.MapperNode.getChild(MapperNode.java:221)
	at org.netbeans.modules.soa.mappercore.Mapper.getNode(Mapper.java:997)
	at org.netbeans.modules.soa.mappercore.Mapper.getNode(Mapper.java:972)
	at org.netbeans.modules.soa.mappercore.Mapper.setExpandedState(Mapper.java:408)
	at org.netbeans.modules.bpel.mapper.model.GraphExpandProcessor.expandGraph(GraphExpandProcessor.java:95)
...
Comment 12 pslechta 2008-06-03 13:34:11 UTC
Hello supernikita,

can you please fix this bug as soon as possible (till 09-Jun-2008), so it can be part of NB 6.1 patch 2?

Thanks!
Comment 13 Nikita Krjukov 2008-06-09 21:05:39 UTC
This issue has a bit misleading instructions. 
So I looked only to latest one (about NPE). 

Also the attached project has a character in an unusual encoding.
So it works with problems on my computer. I changed that character to 
simple 'u' to be able open the project. 

I can't reproduce the NPE on my local NetBeans, 
which is built from the latest sources. 

I get another Exception, when I open the BPEL first time. 
But I don't have any ideas what that exception about. 
And it definitely not related to this issue. 
I will attach my exception for other case. 

Comment 14 Nikita Krjukov 2008-06-09 21:08:58 UTC
Created attachment 62584 [details]
The exception.
Comment 15 Kirill Sorokin 2008-06-09 22:58:15 UTC
There is definitely something wrong here.. :(

1) Don't you consider the possibility of the fact that it is the "character in an unusual encoding", which is causing
the issue? Shouldn't we ALWAYS try to reproduce the exception given the project as it is?

2) You found an exception. Okay, you have no idea what it means. Why not file another bug for that? If it happens,
shouldn't it get fixed?
Comment 16 Kirill Sorokin 2008-06-09 23:17:08 UTC
For the latest exception I've filed issue 136863.
Comment 17 Nikita Krjukov 2008-06-10 20:53:00 UTC
Changes are very small and safe
You can see them here: http://hg.netbeans.org/main/rev/9f081d6560f0
Comment 18 pslechta 2008-06-11 10:04:30 UTC
The fix has been ported into the release61_fixes repository.

http://hg.netbeans.org/release61_fixes/rev/fb2e4d4fba7a
Comment 19 Andrei Chistiakov 2008-06-11 14:48:40 UTC
Verified with NetBeans IDE Dev (Build 20080611100304)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo