Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123637 - Files for merge should be ignored.
Files for merge should be ignored.
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 15:05 UTC by Peter Pis
Modified: 2008-01-18 08:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (1.05 KB, text/plain)
2007-12-10 20:13 UTC, John Rice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2007-12-07 15:05:39 UTC
Product Version: NetBeans IDE 6.0 (Build 200711261600)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Userdir: D:\ide\60daily\user

While merge is run, files like <file_name>.org.212 and similar are created. They should be ignored, but they are locally
new.
Comment 1 John Rice 2007-12-07 19:03:43 UTC
If the user does not have a .hgignore file then one is created and *.orig is added, on Windows it appears that *.orig.*
also needs to be added.

However, there is a general .hgignore problem. 
The problem is that if the user already has a .hgignore file then these entries are never added, so both *.orig and
*.orig.* files will appear as Locally New. We need to look at prompting the user before Merge or Revert Modifications
are run (both can generate *.orig files), if we detect that they have a .hgignore file and it does not have these
entries. If they want at that point we can then add these entries for them.
Comment 2 John Rice 2007-12-07 19:27:02 UTC
Note: we need to make sure to check not just for <project>/.hgignore but also for [ui] ignore=<ignore_file_per_user>
entries in ~/.hgrc as they may be using a custom user wide ignore pattern file.
Comment 3 John Rice 2007-12-10 20:13:24 UTC
Created attachment 54113 [details]
Proposed patch
Comment 4 John Rice 2007-12-10 20:17:41 UTC
Patch fixes Windows specific problem for Merge files only.

Still need generic fix.
Comment 5 John Rice 2007-12-11 22:09:59 UTC
IDE:-------------------------------------------------
IDE: [11/12/07 22:09] Committing started
Checking in HgUtils.java;
/cvs/versioncontrol/mercurial/src/org/netbeans/modules/mercurial/util/HgUtils.java,v  <--  HgUtils.java
new revision: 1.24; previous revision: 1.23
done
IDE: [11/12/07 22:09] Committing finished
Comment 6 Peter Pis 2008-01-18 08:54:06 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo