Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123616 - Clone annotation is not displayed immediately
Clone annotation is not displayed immediately
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
: REGRESSION
: 123629 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 09:05 UTC by Peter Pis
Modified: 2008-01-03 09:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (1.67 KB, patch)
2007-12-07 11:51 UTC, Padraig Obriain
Details | Diff
a better patch (1.22 KB, patch)
2007-12-07 15:12 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2007-12-07 09:05:09 UTC
Product Version: NetBeans IDE 6.0 (Build 200711261600)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Userdir: D:\ide\60daily\user

Steps:
1. Create new project. 
2. Select it and invoke "Versioning | Initialize Mercurial Repository" popup menu action.
3. Commit all changes on the project
4. Select project root and invoke "Mercurial | Clone <Project Name>" action.

The new project is being opened, but the annotation text for project root node is missing.
Comment 1 Padraig Obriain 2007-12-07 11:50:46 UTC
This regression is caused by the change for issue 121354.
Comment 2 Padraig Obriain 2007-12-07 11:51:49 UTC
Created attachment 53983 [details]
proposed patch
Comment 3 Padraig Obriain 2007-12-07 15:12:56 UTC
Created attachment 53996 [details]
a better patch
Comment 4 Padraig Obriain 2007-12-07 15:13:59 UTC
The second p[atch has the benefit that it also fixes issue #123629.
Comment 5 Padraig Obriain 2007-12-07 15:15:50 UTC
*** Issue 123629 has been marked as a duplicate of this issue. ***
Comment 6 Padraig Obriain 2007-12-07 15:55:39 UTC
IDE:-------------------------------------------------
IDE: [12/7/07 3:54 PM] Committing started
Checking in FileStatusCache.java;
/shared/data/ccvs/repository/versioncontrol/mercurial/src/org/netbeans/modules/mercurial/FileStatusCache.java,v  <-- 
FileStatusCache.java
new revision: 1.19; previous revision: 1.18
done
IDE: [12/7/07 3:54 PM] Committing finished
Comment 7 Peter Pis 2007-12-10 06:05:08 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo