Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123366 - File dialog does not show current location
File dialog does not show current location
Status: RESOLVED DUPLICATE of bug 122577
Product: platform
Classification: Unclassified
Component: Directory Chooser
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Denis Anisimov
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 15:04 UTC by emmsna
Modified: 2008-12-22 11:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description emmsna 2007-12-04 15:04:37 UTC
When adding JAR files to the classpath of a project the dropbox in the file dialog only shows 'Desktop' and no other
information about the current path location.  If the 'up directory' button is pressed then the dropbox correctly updates
and shows the current hierarchy.

This problem does NOT occur on other file dialogs, such as Open Project.

As far as I can tell this bug got introduced in one of the later version 6 releases, possibly RC1.
Comment 1 Denis Anisimov 2008-03-04 14:13:22 UTC
Reproduced.
Comment 2 Denis Anisimov 2008-03-04 17:24:59 UTC
The behavior is strange : FileChooser that is opened on button pressing
doesn't want to show full ancestors path in combobox.
But it recognizes correctly the current directory itself and its content.
The problem somewhere around setCurrentDirectory() method.
Skipping of this method call leads to setup user home directory with 
correct ancestors path in combobox. But setting current directory 
with method mentioned above leads to bad values in combobox.
This problem concerns plain Java JFileChooser also , so it seems 
there is some registered services that influence on such behavior.
Comment 3 Denis Anisimov 2008-03-06 07:30:21 UTC
Ok , catch it .
The problem is in swing FileChooserUI implementation: 
com.sun.java.swing.plaf.windows.WindowsFileChooserUI.
This is JDK bug.
Mentioned JFileChooser uses this UI class for rendering 
FileChooser content.
It differs from other FileChoosers ( f.e. Open Project chooser ) 
which is implemented in generic way inside NB and doesn't have such problem.
Comment 4 Lukas Hasik 2008-09-09 17:24:14 UTC

*** This issue has been marked as a duplicate of 122577 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo