Bug 123344 - Common status line
Common status line
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Miloslav Metelka
issues@platform
http://ui.netbeans.org/docs/ui/Common...
: PLAN, UI
: 50363 155453 (view as bug list)
Depends on: 156357
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 13:03 UTC by jrojcek
Modified: 2009-02-19 22:53 UTC (History)
9 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2007-12-04 13:03:47 UTC
Problem description:

Currently the editor has its own status line showing information that could comfortable fit into the global status line. With wide screen monitors the 
horizontal space is quite limited, so saving one line for source code is a plus. NetBeans seems to be the only IDE  that actually has a special status line in 
the editor.

Solution:

Eliminate the the editor status line by moving information it currently displays into the main status line. See the UI spec (maybe needs a refresh):
http://ui.netbeans.org/docs/ui/CommonStatusbar/CommonStatusLineSpecification.html

---

Note that even though I'm filing this issue as part of the 6.1 planning, the real intention is to address this issue in one of the upcoming releases.
Comment 1 Antonin Nebuzelsky 2008-02-21 15:12:25 UTC
Progress indication area, owned by Tomas, is a part of the status line. Assigning to Tomas for now.

Changing TM to future. We'll get back to this request after 6.1.
Comment 2 Ondrej Langr 2008-10-27 16:14:32 UTC
*** Issue 50363 has been marked as a duplicate of this issue. ***
Comment 3 Antonin Nebuzelsky 2008-12-15 12:08:14 UTC
Linking to the new UI spec.

http://ui.netbeans.org/docs/ui/CommonStatusbar/index.html
Comment 4 Antonin Nebuzelsky 2008-12-15 12:20:01 UTC
*** Issue 155453 has been marked as a duplicate of this issue. ***
Comment 5 Stanislav Aubrecht 2009-01-27 14:59:47 UTC
i've extended status displayer api (see #156357), reassigning to mmetelka to implement the editor part
Comment 6 Miloslav Metelka 2009-02-11 17:24:25 UTC
I have implemented the editor part.
http://hg.netbeans.org/main/rev/d554265829ec
Comment 7 Quality Engineering 2009-02-18 10:43:13 UTC
Integrated into 'main-golden', will be available in build *200902180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d554265829ec
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #123344 - Common status line - Editor part implementation.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo