Bug 12327 - java.lang.NullPointerException: Posted StackTrace
java.lang.NullPointerException: Posted StackTrace
Status: CLOSED WORKSFORME
Product: javaee
Classification: Unclassified
Component: Code
3.x
PC Windows 3.1/NT
: P1 (vote)
: 3.x
Assigned To: Milan Kuchtiak
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 09:10 UTC by pcmreddy
Modified: 2001-07-20 20:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pcmreddy 2001-05-22 09:10:37 UTC
This was observed while deploying a web only application to tomcat server.

Tue May 22 01:11:45 BST 2001: java.lang.NullPointerException: Posted StackTrace
Annotation: Exception occurred in Request Processor
org.openide.util.RequestProcessor$Holder: Posted StackTrace(task
org.netbeans.core.ModuleActions$1@3ca41c [-1713, 1, -1])
        at
org.openide.util.RequestProcessor$Task.createHolder(RequestProcessor.java:322)
        at org.openide.util.RequestProcessor.post(RequestProcessor.java:100)
        at org.openide.util.RequestProcessor.post(RequestProcessor.java:73)
        at org.netbeans.core.ModuleActions.invokeAction(ModuleActions.java:89)
        at
org.openide.awt.Actions$ButtonBridge.actionPerformed(Actions.java:351)
        at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1450)
        at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1504)
        at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:378)
        at
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:250)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:279)
[catch] at
javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased(BasicMenuItemUI.java:886)
        at java.awt.Component.processMouseEvent(Component.java:3715)
        at java.awt.Component.processEvent(Component.java:3544)
        at java.awt.Container.processEvent(Container.java:1164)
        at java.awt.Component.dispatchEventImpl(Component.java:2593)
        at java.awt.Container.dispatchEventImpl(Container.java:1213)
        at java.awt.Component.dispatchEvent(Component.java:2497)
        at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:2451)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:2216)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:2125)
        at java.awt.Container.dispatchEventImpl(Container.java:1200)
        at java.awt.Window.dispatchEventImpl(Window.java:914)
        at java.awt.Component.dispatchEvent(Component.java:2497)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:131)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:98)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)
 
Tue May 22 01:11:45 BST 2001: java.lang.NullPointerException: null
java.lang.NullPointerException
        at
org.netbeans.modules.web.tomcat.TomcatServerInstance.listenerRegistering(TomcatServerInstance.java:121)
        at
org.netbeans.modules.web.tomcat.TomcatServerInstance.setTestComponent(TomcatServerInstance.java:95)
        at
org.netbeans.modules.web.tomcat.TomcatServerInstance.deploy(TomcatServerInstance.java:79)
        at
org.netbeans.modules.web.execution.WebDefaultExecPerformer.modulesDeployment(WebDefaultExecPerformer.java:140)
        at
org.netbeans.modules.j2ee.impl.DefaultServerInstanceManager.startDeployment(DefaultServerInstanceManager.java:130)
        at
org.netbeans.modules.j2ee.impl.DefaultServerInstanceManager.serverInstanceDeployment(DefaultServerInstanceManager.java:82)
        at
org.netbeans.modules.j2ee.impl.DefaultExecPerformer.startDeployment(DefaultExecPerformer.java:74)
        at
org.netbeans.modules.j2ee.impl.ServerExecutor.execute(ServerExecutor.java:49)
        at
org.netbeans.modules.j2ee.impl.ServerExecutor.execute(ServerExecutor.java:42)
        at
org.netbeans.modules.j2ee.impl.ExecSupport.start(ExecSupport.java:125)
        at
org.netbeans.modules.j2ee.impl.ServerExecSupport.start(ServerExecSupport.java:118)
        at org.openide.actions.ExecuteAction.execute(ExecuteAction.java:140)
        at org.openide.actions.ExecuteAction.execute(ExecuteAction.java:237)
        at
org.openide.actions.ExecuteAction.performAction(ExecuteAction.java:102)
        at
org.netbeans.modules.j2ee.impl.DeployAction.performAction(DeployAction.java:42)
        at org.openide.util.actions.NodeAction.performAction(NodeAction.java:92)
        at
org.openide.util.actions.NodeAction.actionPerformed(NodeAction.java:83)
        at org.netbeans.core.ModuleActions$1.run(ModuleActions.java:76)
        at org.openide.util.Task.run(Task.java:124)
[catch] at org.openide.util.RequestProcessor$ProcessorThread.run(RequestProcesso
Comment 1 Jesse Glick 2001-05-22 13:43:02 UTC
Fixing category. (Note there is no need to add yourself to the CC list for a bug
you file.)
Comment 2 L Martinek 2001-05-22 14:20:37 UTC
The exception is same as in issue #11904. But it's already fixed and occured 
only during executing JSP outside webmodule.
Comment 3 Petr Jiricka 2001-06-01 08:56:10 UTC
Assigning to the right person.
Comment 4 Milan Kuchtiak 2001-06-01 09:41:45 UTC
I am not able to reproduce this bug
Comment 5 _ hlu 2001-06-12 23:04:00 UTC
Could not reproduce the bug on ee build 010611_1.
Comment 6 _ hlu 2001-06-12 23:05:53 UTC
I am closing this bug as it could not be reproduced.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo