Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123258 - The brace elimination feature *breaks* the code
The brace elimination feature *breaks* the code
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://emu.freenetproject.org/~nextge...
release601_fixes_candidate1 release60...
:
: 123414 124526 131069 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 14:48 UTC by nextgens
Modified: 2008-03-25 17:48 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nextgens 2007-12-03 14:48:10 UTC
The brace elimination feature *breaks* the code. Breaks as in : the generated bytecode is different from the original
one after "formating"

Everything needed to reproduce the bug is available at http://emu.freenetproject.org/~nextgens/testcase.tbz

I've experienced it on both 6.0-rc2 and 6.0.
Comment 1 Dusan Balek 2007-12-04 08:48:39 UTC
Fixed.

Checking in Reformatter.java;
/cvs/java/source/src/org/netbeans/modules/java/source/save/Reformatter.java,v  <--  Reformatter.java
new revision: 1.49; previous revision: 1.48
done
Comment 2 Jiri Prox 2007-12-05 07:49:42 UTC
*** Issue 123414 has been marked as a duplicate of this issue. ***
Comment 3 Jan Lahoda 2007-12-30 20:17:10 UTC
*** Issue 124526 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Prox 2008-01-31 11:05:42 UTC
verified 

Product Version: NetBeans IDE Dev (Build 20080131063200)
Java: 1.6.0_05-ea; Java HotSpot(TM) Client VM 1.6.0_05-ea-b06
Comment 5 Karthikeyan Rajeswaran 2008-02-11 06:49:02 UTC
The fix has been ported into the release601_fixes branch.

Checking in Reformatter.java;
/cvs/java/source/src/org/netbeans/modules/java/source/save/Attic/Reformatter.java,v  <--  Reformatter.java
new revision: 1.41.2.1.4.2; previous revision: 1.41.2.1.4.1
done
Comment 6 kduling 2008-03-25 17:48:14 UTC
*** Issue 131069 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo