Bug 123257 - 25 sec to zoom out VM telemetry graph for 7 days profiling
25 sec to zoom out VM telemetry graph for 7 days profiling
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Solaris
: P3 (vote)
: 6.x
Assigned To: Jiri Sedlacek
issues@profiler
: PERFORMANCE, VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 13:50 UTC by Alexander Kouznetsov
Modified: 2009-05-25 21:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2007-12-03 13:50:44 UTC
Product Version: NetBeans IDE 6.0 (Build 200711261600)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)

Performed steps:
- Profiling had been running for 7 days
- Opened VM Telemtry
- Performed Zoom Out to Fit Windows
- RESULT: It tooked 25 sec to show the whole graph.
Comment 1 J Bachorik 2008-03-29 12:26:06 UTC
changing milestone
Comment 2 Jiri Sedlacek 2008-04-22 13:35:35 UTC
Caused by inefficient algorithm to draw the chart in Fit to Window mode (several values painted to the same pixel). Will
be fixed by charts reimplementation. Similar issue reported as https://visualvm.dev.java.net/issues/show_bug.cgi?id=8.
Comment 3 Jiri Sedlacek 2009-04-30 16:18:04 UTC
Fixed in profiler-main:


changeset:   129409:7f88a1fe08fb
user:        Jiri Sedlacek <jis@netbeans.org>
date:        Thu Apr 30 17:15:11 2009 +0200
summary:     Bugfix #123257 - sampled painting for too many items
Comment 4 Quality Engineering 2009-05-02 18:48:19 UTC
Integrated into 'main-golden', will be available in build *200905021401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7f88a1fe08fb
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #123257 - sampled painting for too many items, various charts performance improvements & fixes


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo