Bug 123118 - [65cat] DND of window groups (modes)
[65cat] DND of window groups (modes)
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 with 1 vote (vote)
: 7.1
Assigned To: Stanislav Aubrecht
issues@platform
plan61
: PLAN, UI
: 140864 147182 (view as bug list)
Depends on: 123114 123110
Blocks: 187276
  Show dependency treegraph
 
Reported: 2007-11-30 10:50 UTC by David Simonek
Modified: 2012-01-16 13:46 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Simonek 2007-11-30 10:50:48 UTC
Description:
- ability to DnD whole tab groups/windows/modes
- drag is started by dragging free area on tab group title
- group can be dropped as whole tab group or into existing tab group
- when tab group is dragged to "sliding" bar, all tabs are made sliding
- ability to DnD whole "sliding" bar at once

Dependencies, risks:
- new view tab layout must be implemented first, editor tab layout modified
- drag ghost image of groups must be implemented first
- winsys DnD infrastructure changes, transferable to hold tab group instead of one component 

Estimation: 4 man weeks
Comment 1 Antonin Nebuzelsky 2007-12-11 10:25:06 UTC
More optimistic estimate is 1-2 weeks.
Comment 2 Lukas Hasik 2008-04-10 21:21:56 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 3 Stanislav Aubrecht 2008-10-16 11:05:22 UTC
*** Issue 140864 has been marked as a duplicate of this issue. ***
Comment 4 Stanislav Aubrecht 2008-10-21 10:56:10 UTC
*** Issue 147182 has been marked as a duplicate of this issue. ***
Comment 5 ulfzibis 2008-10-21 11:29:47 UTC
> - drag is started by dragging free area on tab group title
Hm, I don't see this free area on tab group title ???

Alternatives:
- make separators between the tab groups capable for dragging, see Issue 147182.
  Suggestion: if moving a separator exceeds a reasonable limit (e.g. border of NetBeans main frame),
  action should switch to dragging, and separator should jump back to it's recent position.
- choose free white background of respective open tab window.
  Problem in text areas (e.g. editor, output): also free space is occupied for marking text.
  In this case, free space in windows toolbar could be used.
Comment 6 ulfzibis 2008-10-21 11:33:10 UTC
Just to draw attention to this issue.
It was planned for 6.5.
Comment 7 ulfzibis 2008-10-21 12:40:03 UTC
Related: Issue 150851
Comment 8 Stanislav Aubrecht 2012-01-16 13:46:23 UTC
implemented in 7.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo