Bug 122887 - Facelets support as a standard part of NetBeans
Facelets support as a standard part of NetBeans
Status: RESOLVED DUPLICATE of bug 72556
Product: javaee
Classification: Unclassified
Component: Code
6.x
All All
: P4 with 23 votes (vote)
: 6.x
Assigned To: Petr Pisl
issues@javaee
plan61
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 18:36 UTC by Petr Jiricka
Modified: 2008-06-02 17:52 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2007-11-27 18:36:54 UTC
Include Facelets modules as a part of standard NetBeans 6.1 distribution
Comment 1 nullone 2008-01-15 01:16:54 UTC
hope to have a WYSIWYG GUI interface, better than what Jboss developer studio offers.
Comment 2 gborkowski 2008-03-20 15:33:19 UTC
We have already 6.1 beta, still no facelets support. No facelts plugin on update center. When you take into account the
fact, that probably most of new JSF projects use facelets, this is really big miss from NetBeans. This should get much
higher importance for sure. There is a module on dev.java.net, but documenation says it does not work with 6.0 (in fact
it works, but pretty unstable).
Full WYSIWYG interface would be nice, but this require much work to be done, so it can be planned for future. At this
point the thing which is urgently needed is smooth integration of facelets in NB 6.1 as it is already in aforementioned
module from dev.java.net.
It should at least it should be available from update center for 6.1.
Comment 3 jcampbell 2008-03-20 17:35:03 UTC
I agree with gborkowski, We use facelets with NetBeans 6.0 (using the nbfaceletssupport plugin), but THAT plugin no
longer works with 6.1-Beta!  Please get facelets working with NetBeans 6.1!
Comment 4 jokers 2008-04-24 21:33:24 UTC
visual web editing combined with the strength of component and template developing of facelets, would round up this very
good release!
Comment 5 cofeinesunshine 2008-05-08 03:37:51 UTC
i need this as air every day!!!
Comment 6 nullone 2008-05-31 06:36:33 UTC
I got notice that Netbeans team degraded the priority of this issue from P3 to P5.

Let's go to use Eclipse, and get visual designer support for Facelets!

Comment 7 John Baker 2008-05-31 07:44:29 UTC
No, waiting for standardization .. and looks like this issue is a duplicate of
http://www.netbeans.org/issues/show_bug.cgi?id=72556  (see the last comment)

Also see http://blogs.sun.com/poting/entry/build_and_install_facelets_support
Comment 8 Jayashri Visvanathan 2008-05-31 17:06:03 UTC
Facelets Plugin for 6.1 should be available on beta update center by next week. Please stay tuned. I'll update the issue
as soon as it is posted. Meanwhile please feel free the use the nbms off of Po-Ting's blog. It should be same version.

Facelets will be part of NetBeans 7 since it is part of JSF 2.0
thanks
Comment 9 Petr Jiricka 2008-06-02 17:50:02 UTC
> I got notice that Netbeans team degraded the priority 

Was it? I don't think this was anyone from the NetBeans team.
Comment 10 Petr Jiricka 2008-06-02 17:52:33 UTC
I agree this is a duplicate of #72556. Resolving as duplicate.

*** This issue has been marked as a duplicate of 72556 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo