Bug 122886 - GlassFish v3 plugin on the update center
GlassFish v3 plugin on the update center
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
6.x
All All
: P1 (vote)
: 6.x
Assigned To: _ pcw
issues@serverplugins
plan61
: PLAN
Depends on:
Blocks: 123131
  Show dependency treegraph
 
Reported: 2007-11-27 18:10 UTC by Petr Jiricka
Modified: 2008-04-07 21:50 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2007-11-27 18:10:55 UTC
Provide a server plugin for GlassFish v3 and publish it on the update center for NetBeans 6.1.
Comment 1 _ pcw 2008-02-27 23:19:09 UTC
This plugin (the one that supports V3 for both Web apps and JRuby apps) is composed of 3 modules in main/contrib:

glassfish.common : Core server code that manages and offers an api for shared server instances of GlassFish V3.
glassfish.javaee : Implements j2eeserver's server apis (JSR-88 ++) on top of glassfish.common.
glassfish.jruby : Implements ruby.railsproject's server api on top of glassfish.common.

Code is generally working at this writing.  I'm adding incremental features to fill out the capabilities and smooth out
the usability (esp. for JRuby - j2eeserver is pretty solid).

Note the older V3 plugin that supports Web apps only is still available and is on the update center.
Comment 2 _ pcw 2008-04-07 21:50:07 UTC
The modules for this plugin are on the dev update center, are generally stable and feature complete for the TP2 V3
feature set.  Both JavaEE and JRuby/Rails applications are supported.

Ongoing tasks (not tracked by this issue) are incremental bug and feature upgrades tracking V3's capabilities and pushes
to beta update center as those upgrades become stable enough for that.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo