Bug 122799 - Library Manager doesn't recognize Javadoc zip files added via a UNC path
Library Manager doesn't recognize Javadoc zip files added via a UNC path
Status: RESOLVED DUPLICATE of bug 46813
Product: projects
Classification: Unclassified
Component: Libraries
6.x
All Windows XP
: P4 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 18:48 UTC by jschek
Modified: 2007-12-07 16:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jschek 2007-11-26 18:48:48 UTC
The Library Manager will return an error "The javadoc root does not contain the index-files folder or the index-
all.html file." when the javadoc root is a UNC path. If I add the same javadoc through a mounted drive or a local 
path, the Javadoc works fine.

Javadocs added using a UNC through the Java Platform Manager seems to work fine.

The easiest way I found to recreate the problem is to add the JDK javadocs to a newly created library (this is a 
known, working javadoc that should always succeed). Adding using the UNC will fail; adding using a local path will 
succeed:

\\mymachine\c$\Development\jdk\jdk-6-doc.zip  FAIL
C:\Development\jdk\jdk-6-doc.zip SUCCESS

This is running on:
Product Version: NetBeans IDE Dev (Build 200711260000)
Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b06
System: Windows 2003 version 5.2 running on x86; Cp1252; en_US (nb)
Comment 1 Peter Pis 2007-12-04 09:43:43 UTC
Reassigning to "projects".
Comment 2 Tomas Zezula 2007-12-04 16:50:45 UTC

*** This issue has been marked as a duplicate of 46813 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo