Bug 122794 - com.sun.jdi.ObjectCollectedException at com.sun.tools.jdi.JDWPException.toJDIException
com.sun.jdi.ObjectCollectedException at com.sun.tools.jdi.JDWPException.toJDI...
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, release60_fixes_ca...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 17:37 UTC by Dan Kolar
Modified: 2007-12-12 16:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.46 KB, text/plain)
2007-11-26 17:37 UTC, Dan Kolar
Details
stacktrace (2.46 KB, text/plain)
2007-11-30 11:02 UTC, Radim Roska
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Kolar 2007-11-26 17:37:26 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b02
OS: Windows XP, 5.1, x86

User Comments: 
1) Set breakpoint in .jsp
2) Debug file

Exception is thrown
Comment 1 Dan Kolar 2007-11-26 17:37:32 UTC
Created attachment 53500 [details]
stacktrace
Comment 2 Dan Kolar 2007-11-26 17:40:27 UTC
This happen with glassfish v2ur1 b09
Comment 3 Martin Entlicher 2007-11-26 20:48:33 UTC
Please provide the JSP file and the condition which you've set to the breakpoint, so that we can reproduce the problem.
It looks like the fix will be simply not to evaluate expressions for which we do not have loaded classes in the VM.
Comment 4 Dan Kolar 2007-11-27 10:14:33 UTC
1) Create new web project J2EE5 on this version of glassfish
2) Put breakpoint on line 17 in index.jsp
3) Debug project/file

Exception rises.
Comment 5 Martin Entlicher 2007-11-27 10:41:13 UTC
It's not reproducible without the condition that is set on the breakpoint. Please provide that as well. Thanks.
Comment 6 Martin Entlicher 2007-11-27 13:33:31 UTC
The exception is really strange and might be specific to web server. It looks like the class loader was collected :-/
Javadoc does not mention that Method.argumentTypes() can ever throw ObjectCollectedException. I'll add a catch for that.
Comment 7 Martin Entlicher 2007-11-27 13:43:43 UTC
The catch is added, so please verify whether it helps:

/shared/data/ccvs/repository/debuggerjpda/src/org/netbeans/modules/debugger/jpda/expr/Evaluator.java,v  <--  Evaluator.java
new revision: 1.41; previous revision: 1.40
Comment 8 Dan Kolar 2007-11-27 18:01:49 UTC
v.
Comment 9 Radim Roska 2007-11-30 11:02:28 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_05-ea-b05
OS: Linux, 2.6.22-14-generic, i386

User Comments: 
steps to reproduce :

0. install latest gf from https://glassfish.dev.java.net/downloads/v2ur1-b09a.html
1. create ear project on latest GF
2. debug created project
3. this exception occurs..

it is not happening on older gf builds
Comment 10 Radim Roska 2007-11-30 11:02:32 UTC
Created attachment 53708 [details]
stacktrace
Comment 11 pgebauer 2007-12-03 14:08:49 UTC
The fix has been ported into the release60_fixes branch.

Checking in Evaluator.java;
/cvs/debuggerjpda/src/org/netbeans/modules/debugger/jpda/expr/Evaluator.java,v  <--  Evaluator.java
new revision: 1.39.4.1; previous revision: 1.39
done
Comment 12 Jiri Vagner 2007-12-10 16:29:01 UTC
I'm not able to reproduce it on nb6 without patch. Dan, can you please check it on nb 6.0 without and with patch1?

I tried to reproduce it on ....
Sun Java System Application Server 9.1_01 (build b09a-fcs) - from glassfish-installer-v2ur1-b09a-windows.jar 
Sun Java System Application Server 9.1 (build b58g-fcs) - boundled with nb 6.0

Product Version: NetBeans IDE 6.0 (Build 200711261600)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo