Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122605 - Post-Creation Code is not refactored
Post-Creation Code is not refactored
Status: RESOLVED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
PC Windows Vista
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 20:43 UTC by rvojta
Modified: 2007-11-23 10:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rvojta 2007-11-22 20:43:30 UTC
NetBeans 6.0 RC2, Windows Vista.

Create JDialog form and name it MyDialog for example. Create private method MyDialog.MyMethod. Put JComboBox control in
to MyDialog and add 'MyMethod();' as Post-Creation Code in form editor for JComboBox control. Switch to source code, hit
the right mouse button on MyMethod() and rename it (Refactor -> Rename) to MyRefactoredMethod(). MyMethod() is
successfully renamed to MyRefactoredMethod(), but the MyMethod() in JComboBox's Post-Creation Code is not modified -
still contains call to MyMethod() -> after refactoring, I'm unable to compile my code.

IMHO MyMethod() call should be changed to MyRefactoredMethod() call in Post-Creation Code too.
Comment 1 Jan Stola 2007-11-23 10:54:09 UTC
This is one of unsupported refactoring scenarios in GUI Builder.
See issue 106831 (Updating embedded custom code - entered by the user in the GUI builder).

*** This issue has been marked as a duplicate of 106831 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo