Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122347 - value of new property is taken from the currently selected entry
value of new property is taken from the currently selected entry
Status: VERIFIED FIXED
Product: utilities
Classification: Unclassified
Component: Properties
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: Marian Petras
issues@utilities
JA_COMMUNITY, 61fixes1-fixed
:
: 123353 123806 130228 130569 131470 132139 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 03:13 UTC by Masaki Katakai
Modified: 2008-06-04 08:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2007-11-20 03:13:22 UTC
Product Version: NetBeans IDE 6.0 RC2 (Build 200711171200)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b02
System: SunOS version 5.11 running on x86; ISO646-US; en (nb)

When I tried to add new property, the selected value will be added.
It should be blank because I do not put any value in "New Property" dialog.
Here is the step to reproduce.

1. "Open" Bundle.properties in a project
2. Property Editor is opened
3. Put cursor on Value field of existing properties.
4. Click "New Property" button
5. Add something to "Key" field, leave Value field as blank.
6. Click OK button

Now new property is added into table. Key is correct but
Value is not blank, selected Value of existing field will be added.
It should be blank.
Comment 1 Masaki Katakai 2007-11-20 03:15:40 UTC
"Comment" field will be also re-used in newly added property.
Comment 2 Marian Petras 2007-11-20 08:07:22 UTC
Confirmed (dev. build 071106, JDK 1.5.0_13, Linux, x86, 32-bit).
Comment 3 Marian Petras 2008-03-20 10:45:53 UTC
*** Issue 130569 has been marked as a duplicate of this issue. ***
Comment 4 Marian Petras 2008-03-30 13:44:37 UTC
*** Issue 123353 has been marked as a duplicate of this issue. ***
Comment 5 Marian Petras 2008-03-30 13:45:27 UTC
*** Issue 123806 has been marked as a duplicate of this issue. ***
Comment 6 Marian Petras 2008-03-30 13:49:29 UTC
*** Issue 130228 has been marked as a duplicate of this issue. ***
Comment 7 Marian Petras 2008-03-30 13:51:50 UTC
There is additional information about this issue in bug report #130228.
Comment 8 Marian Petras 2008-03-30 13:59:03 UTC
*** Issue 131470 has been marked as a duplicate of this issue. ***
Comment 9 rbalada 2008-04-07 08:57:38 UTC
*** Issue 132139 has been marked as a duplicate of this issue. ***
Comment 10 Marian Petras 2008-04-17 21:24:36 UTC
This bug is caused by contention of two routines manipulating with cell selection of the table.

One routine is called every time the cell selection is changed and its goal is to correct cell selection if the
selection should be cleared - in this case, it corrects the selection such that the cell corresponding to the last
selected bundle entry (key/value pair) is selected.

The second routine just selects the cell corresponding to the value just added by the user.

Because addition of a new key/value pair comprises change of cell selection, both of these routines are called when the
user adds a new entry which caused the symptoms described in this bug report.
Comment 11 Marian Petras 2008-04-18 09:43:26 UTC
Fixed.

The fix is quite simple - it temporarily disables the selection-correcting routine for the period of time when a new
property is being added to the resource bundle. The result is that this correction routine does not override the
selection determined by the routine for addition of a new bundle entry.

Changeset:
http://hg.netbeans.org/main/rev/b7541129cbe4
Comment 12 Jana Maleckova 2008-04-23 09:18:10 UTC
is ready for patch1

verified on 
Product Version: NetBeans IDE Dev (Build 20080423054047)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Comment 13 rbalada 2008-04-25 16:58:35 UTC
Merged into release61_fixes repository
changeset:   77443:4c4d6839d177
user:        mpetras@netbeans.org
date:        Thu Apr 17 22:26:42 2008 +0200
summary:     fixed bug #122347 - "value of new property is taken from the currently selected entry"
Comment 14 Jana Maleckova 2008-05-16 15:43:44 UTC
verified on patch 1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo