Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122315 - IDE hangs while after creating missing data source.
IDE hangs while after creating missing data source.
Status: RESOLVED DUPLICATE of bug 121694
Product: ide
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: issues@ide
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 17:11 UTC by rptmaestro
Modified: 2007-11-22 17:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log file (172.08 KB, text/plain)
2007-11-19 17:12 UTC, rptmaestro
Details
Screenshot of frozen IDE (35.86 KB, image/jpeg)
2007-11-22 17:05 UTC, rdelaplante
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rptmaestro 2007-11-19 17:11:23 UTC
Using NetBeans IDE 6.0 RC1.
I made a new install of NB 6.0 RC1. I did not import old settings. After opening my project I got warnings about missing
libraries, web server, and data sources. I resolved the warnings for the libraries and the server, but after creating
the missing data source, the IDE hung.
Comment 1 rptmaestro 2007-11-19 17:12:14 UTC
Created attachment 53220 [details]
messages.log file
Comment 2 rptmaestro 2007-11-19 17:35:31 UTC
As soon as I restarted the IDE, it happened again with another missing data source in a separate web application, so it
appears to be reproducible. Both are oracle connections.
Comment 3 Jiri Prox 2007-11-22 09:43:23 UTC
Please capture a threaddump while IDE is frozen and attach it here.
Thanks
Comment 4 rdelaplante 2007-11-22 17:04:52 UTC
Issue 121694 appears to be a dupe of this.  Why is it a P3?  I think it should be P1 - total IDE lockup.

I experience this too. I opened a web project and it had an unresolved datasource issue.  I used the dialog to resolve
the issue.  After I finished the main resolve datasource dialog froze and the entire IDE froze. I had to kill java.exe
process and restart the IDE.  Once restarted, it no longer reported an unresolved datasource dependency.

Comment 5 rdelaplante 2007-11-22 17:05:52 UTC
Created attachment 53378 [details]
Screenshot of frozen IDE
Comment 6 Jiri Prox 2007-11-22 17:58:59 UTC
You're right, I'm marking this as duplicate of issue 121694, (#121169 is older and it's already reassigned to proper
component).  
If the deadlock is reproducible then it should be P1 of course. 
Anyway, for evaluation the problem we need the threaddump, it will show where is the problem.

*** This issue has been marked as a duplicate of 121694 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo