Bug 122231 - Binding: Wrong setAsString for object with Boolean field
Binding: Wrong setAsString for object with Boolean field
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Web Services
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Michal Skvor
issues@mobility
release601_fixes_candidate1, release6...
: SIMPLEFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 19:49 UTC by Lukas Hasik
Modified: 2008-02-20 18:15 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2007-11-18 19:49:03 UTC
11/18 dev build

-when there is a Object with a Boolean field and user generates a MC2WA with Databnding structures then following code
is generated

    public void setAsString(String dataItemName, String value) throws DataBindingException {
        if( "myBoolean".equals( dataItemName )) {
!            myBoolean = Boolean.parseBoolean( value );
            return;
        }
Comment 1 Lukas Hasik 2007-11-19 09:04:44 UTC
to reproduce - generate MC2WA for methods in
http://www.netbeans.org/nonav/issues/showattachment.cgi/53105/WebAppWSCustomTypes.zip
increasing priority, wrong/uncompilable code generated
Comment 2 Lukas Hasik 2007-12-03 09:31:55 UTC
seems to be fine with the provided jars for testing

    public void setAsString(String dataItemName, String value) throws DataBindingException {
        if( "myBoolean".equals( dataItemName )) {
            myBoolean = "true".equals( value );
            return;
        }
Comment 3 Michal Skvor 2007-12-03 10:48:52 UTC
Fixed:
Checking in Utils.java;
/cvs/mobility/end2end/src/org/netbeans/modules/mobility/e2e/mapping/Utils.java,v  <--  Utils.java
new revision: 1.11; previous revision: 1.10
done
Comment 4 Lukas Hasik 2007-12-03 14:50:40 UTC
verified in trunk build #4671 from deadlock.netbeans.org

Product Version: NetBeans IDE Dev (Build 20071203113754)
Comment 5 Lukas Hasik 2008-01-10 10:05:05 UTC
krajeswaran, are you sure that this issue was fixed for 6.0.1?
IMO, it wasn't integrated into release6.0 branch. I'm removing the status whiteboard
Comment 6 Karthikeyan Rajeswaran 2008-01-10 22:40:26 UTC
Adding the status whiteboard back. (The issue is not fixed for 6.0. The status whiteboard only marks it as a candidate
for 6.0.1 patch1).
Comment 7 pgebauer 2008-02-07 15:13:46 UTC
The fix has been ported into the release601_fixes branch.

Checking in Utils.java;
/cvs/mobility/end2end/src/org/netbeans/modules/mobility/e2e/mapping/Attic/Utils.java,v  <--  Utils.java
new revision: 1.10.8.1; previous revision: 1.10
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo