Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122139 - IDE hangs for memory profiling web application on JBoss server
IDE hangs for memory profiling web application on JBoss server
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: issues@profiler
issues@profiler
release601_fixes_candidate1, release6...
:
: 128635 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 12:39 UTC by Maksim Khramov
Modified: 2008-02-29 15:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (15.52 KB, text/plain)
2007-11-16 12:41 UTC, Maksim Khramov
Details
thread dump (23.13 KB, text/plain)
2007-11-16 12:41 UTC, Maksim Khramov
Details
thread dump (22.52 KB, text/plain)
2007-11-16 12:41 UTC, Maksim Khramov
Details
JBoss thread dump (38.12 KB, text/plain)
2007-11-16 12:42 UTC, Maksim Khramov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim Khramov 2007-11-16 12:39:56 UTC
Product Version: NetBeans IDE 6.0 RC1 (Build 200711160000)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Linux version 2.6.22-14-generic running on i386; UTF-8; ru_RU (nb)
JBoss server 4.2.2

Perform memory profiling ServletExamples sample application.
Select record both object creation and GC
Select Record stack trace option.
Click run

After a time IDE hungs.
I attached a couple thread dups from IDE and JBoss JVM.
Comment 1 Maksim Khramov 2007-11-16 12:41:12 UTC
Created attachment 53114 [details]
thread dump
Comment 2 Maksim Khramov 2007-11-16 12:41:29 UTC
Created attachment 53115 [details]
thread dump
Comment 3 Maksim Khramov 2007-11-16 12:41:45 UTC
Created attachment 53116 [details]
thread dump
Comment 4 Maksim Khramov 2007-11-16 12:42:15 UTC
Created attachment 53117 [details]
JBoss thread dump
Comment 5 Alexander Kouznetsov 2007-11-16 18:47:07 UTC
Reproduced with
Product Version: NetBeans IDE 6.0 RC1 (Build 200711160000)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

Tried to start customized memory profiling for JBossTest application: allocation, record stack traces, limit stack depth
to 2 frames, don't run garbage collection, enable threads monitoring. After a long instrumentation phase Profiler
complained that profiled application doesn't respond. Had to cancel profiling.
Comment 6 J Bachorik 2007-12-11 14:21:03 UTC
fixed problem with communication related deadlock under right circumstances

Checking in SameNameClassGroup.java;
/cvs/profiler/libs/jfluid/src/org/netbeans/lib/profiler/classfile/SameNameClassGroup.java,v  <--  SameNameClassGroup.java
new revision: 1.2; previous revision: 1.1
done
Comment 7 Maksim Khramov 2008-02-01 16:56:20 UTC
Verified in Netbeans 6.1 Build 200801311204
Comment 8 pgebauer 2008-02-05 22:55:20 UTC
The fix has been ported into the release601_fixes branch.

Checking in SameNameClassGroup.java;
/cvs/profiler/libs/jfluid/src/org/netbeans/lib/profiler/classfile/Attic/SameNameClassGroup.java,v  <-- 
SameNameClassGroup.java
new revision: 1.1.12.1; previous revision: 1.1
done
Comment 9 mariadavydova 2008-02-15 14:49:10 UTC
verified.
Build: NetBeans IDE 6.0.1 (Build 200801291616) with NB601 Patch1
Comment 10 Tomas Hurka 2008-02-29 15:31:52 UTC
*** Issue 128635 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo