Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122063 - Focus problem switching between Netbeans and other apps
Focus problem switching between Netbeans and other apps
Status: RESOLVED DUPLICATE of bug 73960
Product: ide
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P4 (vote)
: TBD
Assigned To: issues@ide
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 20:47 UTC by volkmuth
Modified: 2007-11-16 09:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (105.76 KB, image/png)
2007-11-15 20:48 UTC, volkmuth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description volkmuth 2007-11-15 20:47:04 UTC
With Netbeans 6.0 RC1 on MS Windows XP I see the following behavior when using Alt + tab to switch between applications 
while the cursor is in the Netbeans edit window.

If I hold down Alt for 1 second, then press tab once, then release the Alt key I will switch from Netbeans to another 
app.  If I hold down Alt for 1 second, then press tab once, then release the Alt key I switch back to Netbeans and the 
cursor remains in the edit window as expected.

However if I press Alt followed by tab quickly, releasing both nearly simultaneously (probably 10's of milliseconds 
from the pressing of Alt to the pressing of tab), the app switch occurs but when I Alt + tab back to Netbeans the focus 
will be on the menubar rather than in the editor.  Hitting Alt one more time returns the focus to the editor.

Attached is a screenshot.  You'll notice that IE is the active app but the Netbeans menu bar is activated in the 
background.

Netbeans behaves the same way other apps do if you just press Alt, then switch apps using the mouse (i.e. when Netbeans 
loses app focus the menubar is no longer active & the focus will be in the right place when you use the mouse to come 
back to it).

I did not see this with Netbeans 5.5, I don't remember if I saw it with the 6.0 Beta I tried.  This is an admittedly 
minor issue but definitely noticeable if you habitually use Alt+tab.
Comment 1 volkmuth 2007-11-15 20:48:00 UTC
Created attachment 53080 [details]
Screenshot
Comment 2 Jana Maleckova 2007-11-16 09:18:46 UTC

*** This issue has been marked as a duplicate of 73960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo