Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 121923 - Refactoring JSR-296 @Action method doesn't work
Refactoring JSR-296 @Action method doesn't work
Status: RESOLVED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: App Framework
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 15:57 UTC by mrmorris
Modified: 2008-01-11 15:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrmorris 2007-11-14 15:57:14 UTC
When you refactor a method that is annotated with a JSR-296 @Action (and thus used by UI elements) NetBeans fails to
refactor the action due to it being burried inside a string token:
SomeActionComponent.setAction(actionMap.get("someActionInTheActionMap"));

This can be hard to spot since there is no warning or error of any kind, the application simply stops invoking any action.
Comment 1 Jiri Prox 2007-11-15 10:42:44 UTC
IMO this should be handled by separate refactoring plugin
Comment 2 Tomas Pavek 2008-01-11 15:59:45 UTC
We should support renaming the action methods by updating the name everywhere. It is a known limitation of the current
refactoring integration.

*** This issue has been marked as a duplicate of 106831 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo