Bug 12183 - IDE won't launch at all if installed netbeans folder path name contains space(s)
IDE won't launch at all if installed netbeans folder path name contains space(s)
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
Sun Solaris
: P2 (vote)
: TBD
Assigned To: _ ttran
issues@platform
: SPACE_IN_PATH
: 12184 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 20:09 UTC by yvon
Modified: 2008-12-23 12:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
patched runide.sh for starting from dir with spaces (6.91 KB, text/plain)
2001-07-20 20:38 UTC, Jan Zajicek
Details
runide.sh - final patch (userdir patched too) (6.92 KB, text/plain)
2001-07-20 20:38 UTC, Jan Zajicek
Details
diff against rev #1.26 (3.68 KB, text/plain)
2002-01-29 16:56 UTC, Jan Zajicek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yvon 2001-05-14 20:09:51 UTC
OS X allows folders with spaces in their names.  NetBeans needs to accomodate this.

To test, moving my netbeans folder up to the / directory allowed me to launch fine.
Comment 1 yvon 2001-05-14 20:18:49 UTC
See related issue 12184.
Comment 2 Jan Zajicek 2001-05-15 14:08:21 UTC
As I can remember, this is not supported. Am I right, Yarda? If so, please mark
as resolved remind or won't fix.
Comment 3 Jaroslav Tulach 2001-05-17 08:52:24 UTC
Well, I do not know ;-( I somehow remember that the decission was not mine, more
I guess, Martin Balin and Ian could know something about it. Sorry.
Comment 4 Jan Zajicek 2001-05-18 16:56:31 UTC
*** Issue 12184 has been marked as a duplicate of this issue. ***
Comment 5 Jan Zajicek 2001-05-18 17:02:41 UTC
Ok, played a little with double quotes and backslashes ;-) looks like I solved
the neverending story with starting the ide from folder with spaces. Diff is
little bit complicated, so attaching 'runide.sh' from the development build.
Please check it and submit feedback. Of course there may be still problems when
userdir contains spaces, I will look at this ASAP.
Comment 6 Jan Zajicek 2001-05-18 17:04:09 UTC
Created attachment 1388 [details]
patched runide.sh for starting from dir with spaces
Comment 7 Jan Zajicek 2001-05-21 12:25:27 UTC
Created attachment 1391 [details]
runide.sh - final patch (userdir patched too)
Comment 8 _ ttran 2001-07-10 23:13:00 UTC
vstejskal is now the maintainer of the launcher
Comment 9 _ ttran 2001-11-22 21:42:40 UTC
The shell script launcher does not support ide/user dir which contains
spaces.  Very hard to do it right using shell scripts.  JDK on Unix
does not support it either.

We should document this requirement.
Comment 10 Jan Zajicek 2001-11-23 08:15:43 UTC
??? Did I miss something? Attached sh launcher works with spaces in
install dir and userdir.
Comment 11 Jan Zajicek 2002-01-29 16:55:48 UTC
Reopenning. Still none comments from Trung. I'll attch diff against
trunk, that solves using spaces in userdir, in ide installation
directory and in jdk installation directory on Unixs. I tested
execution, compilation, debugging, projects switching, new from
template. Everything works ok. CCing Jesse to review.
Comment 12 Jan Zajicek 2002-01-29 16:56:43 UTC
Created attachment 4481 [details]
diff against rev #1.26
Comment 13 _ ttran 2002-03-07 13:51:23 UTC
Okay, I'm going to put more works on this issue
Comment 14 Jesse Glick 2002-03-07 14:22:30 UTC
You tested running AU too?

The diff looks OK to me. Since it's shell script, I don't really
pretend to understand why quotes are needed where they are; you just
keep adding nested quotes until it works. :-)

BTW - Unix 1.4 JDK seems to no longer use shell scripts for the
wrappers, just ELF executables.

If any bug needs the SPACE_IN_PATH keyword, it is this one.
Comment 15 Jan Zajicek 2002-03-11 11:19:47 UTC
I added quotes where I have thought they should be and then just kept
adding till it works ;-)

I forgot test AU - will do it soon.
Comment 16 _ ttran 2002-03-18 13:30:30 UTC
I am going to commit the patch (with some additional modifications)
soon.  Also tested AU.  Looks fine, except that AU does not place the
module and its lib in the central dir even though the module is marked
as "global".  Try Logger module.  Not sure if this is runide.sh's
fault or AU's fault.  Please check this.
Comment 17 _ ttran 2002-03-18 16:13:53 UTC
okay, refined patch integrated into CVS trunk.  jzajicek, thanks for
your persistence :-)
Comment 18 _ ttran 2002-04-02 12:28:35 UTC
*** Issue 22002 has been marked as a duplicate of this issue. ***
Comment 19 _ ttran 2002-04-11 09:03:02 UTC
this is fixed only in 3.4 dev
Comment 20 _ ttran 2002-04-11 09:14:46 UTC
*** Issue 22002 has been marked as a duplicate of this issue. ***
Comment 21 Mark Dey 2002-07-11 00:47:26 UTC
Need to reopen this issue so that the fix gets back ported to the
sierra branch ASAP. QA wants to begin testing SPACE_IN_PATH this week
but without this bugfix for Solaris, they won't be able to get past
runide.sh. 
Comment 22 Jesse Glick 2002-07-11 15:00:24 UTC
It is fixed in the trunk, hence resolution FIXED is correct. If the
fix is merged to Sierra branch, the Target Milestone can be set back
to Sierra (a milestone version which has yet to be created in IZ BTW).
Comment 23 _ ttran 2002-07-12 12:50:43 UTC
sync'ed runide.sh in sierra branch to rev 1.36, thus fixed this bug
for S1S 4.1
Comment 24 Marian Mirilovic 2002-07-25 10:17:13 UTC
verified in [sierra](020724)
Comment 25 Marian Mirilovic 2002-09-05 18:03:06 UTC
verified in nb3.4


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo