Bug 121712 - NullPointerException at org.netbeans.modules.web.webmodule.WebModuleExtenderBridge.update
NullPointerException at org.netbeans.modules.web.webmodule.WebModuleExtenderB...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Andrei Badea
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, release601_fixes_c...
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 11:20 UTC by glasgow4
Modified: 2008-02-20 18:18 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.61 KB, text/plain)
2007-11-27 14:51 UTC, shenoudab
Details

Note You need to log in before you can comment on or make changes to this bug.
Description glasgow4 2007-11-12 11:20:30 UTC
Build: NetBeans IDE 6.0 RC1 (Build 200711081200)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments:
Comment 1 Milos Kleint 2007-11-12 12:45:16 UTC
->web
Comment 2 Tomas Mysik 2007-11-12 16:29:30 UTC
Reassigning after the discussion with Andrei.
Comment 3 Tomas Mysik 2007-11-12 16:43:40 UTC
Forgot to reassign.
Comment 4 shenoudab 2007-11-27 14:51:05 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
after adding the OpenPortal Plugin and create a new Project 
and open the Project Properties and go to Framework node that exception appears
Comment 5 shenoudab 2007-11-27 14:51:09 UTC
Created attachment 53551 [details]
stacktrace
Comment 6 Andrei Badea 2007-12-13 13:16:32 UTC
Fixed.

Checking in src/org/netbeans/modules/web/webmodule/WebModuleExtenderBridge.java;
/cvs/web/webapi/src/org/netbeans/modules/web/webmodule/WebModuleExtenderBridge.java,v  <--  WebModuleExtenderBridge.java
new revision: 1.4; previous revision: 1.3
done
Checking in test/unit/src/org/netbeans/modules/web/webmodule/WebModuleExtenderBridgeTest.java;
/cvs/web/webapi/test/unit/src/org/netbeans/modules/web/webmodule/WebModuleExtenderBridgeTest.java,v  <-- 
WebModuleExtenderBridgeTest.java
new revision: 1.4; previous revision: 1.3
done
Comment 7 Andrei Badea 2007-12-13 13:19:33 UTC
Reporter: please verify that the issue is fixed in a NetBeans daily build newer than December 13. Thanks.
Comment 8 Jindrich Sedek 2008-01-31 15:14:38 UTC
described scenario seems to be working well to me
verified.

NetBeans IDE Dev (Build 200801310006)
Comment 9 khu 2008-02-11 17:22:59 UTC
The fixes have been ported into the release601_fixes branch.

Checking in WebModuleExtenderBridge.java;
/cvs/web/webapi/src/org/netbeans/modules/web/webmodule/Attic/WebModuleExtenderBridge.java,v  <-- 
WebModuleExtenderBridge.java
new revision: 1.3.8.1; previous revision: 1.3
done
Checking in WebModuleExtenderBridgeTest.java;
/cvs/web/webapi/test/unit/src/org/netbeans/modules/web/webmodule/Attic/WebModuleExtenderBridgeTest.java,v  <-- 
WebModuleExtenderBridgeTest.java
new revision: 1.3.8.1; previous revision: 1.3
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo