Bug 121711 - Code Completion deletes lines in file
Code Completion deletes lines in file
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Completion
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vladimir Voskresensky
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 11:09 UTC by soldatov
Modified: 2007-11-19 14:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
patch (1.82 KB, patch)
2007-11-12 16:35 UTC, Vladimir Voskresensky
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2007-11-12 11:09:29 UTC
Steps:
- Run Netbeans 6.0RC1
- Create project
- Create C++ header file
- Move cursor in next line after "#endif	/* _NEWFILE1_H */"
- Press Ctrl-space
==> All strings after "#define	_NEWFILE1_H" disappeared from editor
Comment 1 Vladimir Voskresensky 2007-11-12 16:29:52 UTC
the problem is that we lost offset of called completion in case of some tokens sequences:
# tokens or comment, whitespace tokens
Comment 2 Vladimir Voskresensky 2007-11-12 16:33:29 UTC
fixed:
- clear expression stack on #-token
- add empty variable to remember final offset when tokenizing was finished with whitespace or comments
Comment 3 Vladimir Voskresensky 2007-11-12 16:35:17 UTC
Created attachment 52888 [details]
patch
Comment 4 Alexander Pepin 2007-11-13 16:07:47 UTC
verified in trunk build 20071113
Comment 5 Jesse Grodnik 2007-11-14 15:36:50 UTC
Following high resistance process ...
Comment 6 Vladimir Kvashin 2007-11-14 18:32:59 UTC
I reviewed the fix.
I believe it is correct and safe.
Comment 7 Vladimir Voskresensky 2007-11-16 13:03:27 UTC
cvs commit into release60:
Checking in CsmCompletionTokenProcessor.java;
/shared/data/ccvs/repository/cnd/completion/src/org/netbeans/modules/cnd/completion/cplusplus/ext/CsmCompletionTokenProcessor.java,v
 <--  CsmCompletionTokenProcessor.java
new revision: 1.15.2.1; previous revision: 1.15
done
Comment 8 Alexander Pepin 2007-11-19 14:07:58 UTC
verified in RC2 candidate build


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo