Bug 121513 - java.net.URISyntaxException: Illegal character in path at index 36: file:/Applications/NetBeans/NetBeans 6.0 Dev 200711041200.app/Contents/Resources/NetBeans/enterprise4/docs/jstl11-doc.zip
java.net.URISyntaxException: Illegal character in path at index 36: file:/App...
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 20:47 UTC by Martin Schovanek
Modified: 2009-05-18 10:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2007-11-08 20:47:53 UTC
Build: NetBeans IDE Dev (Build 200711070000)
VM: Java HotSpot(TM) Client VM, 1.5.0_07-87
OS: Mac OS X, 10.4.10, i386

User Comments: 
to reproduce:
-----------
1) have a .jsp with jstl/sql taglibrary
2) type <sql:quer|
3) invoke CC
4) click Browser icon at CC Doc window
ERROR: IDE throws the java.net.URISyntaxException

Looks like space-in-path problem.
Comment 1 Lukas Hasik 2007-11-09 10:35:51 UTC
java.net.URISyntaxException: Illegal character in path at index 16: file:/C:/Program Files/NetBeans Ruby
IDE/ide8/docs/html40.zip
        at java.net.URI$Parser.fail(URI.java:2809)
        at java.net.URI$Parser.checkChars(URI.java:2982)
        at java.net.URI$Parser.parseHierarchical(URI.java:3066)
        at java.net.URI$Parser.parse(URI.java:3014)
        at java.net.URI.(URI.java:578)
        at org.netbeans.core.startup.layers.ArchiveURLMapper.getFileObjects(ArchiveURLMapper.java:97)
        at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:188)
        at org.netbeans.modules.extbrowser.URLUtil.createExternalURL(URLUtil.java:77)
        at org.netbeans.modules.extbrowser.NbDdeBrowserImpl$URLDisplayer.dispatchURL(NbDdeBrowserImpl.java:304)
        at org.netbeans.modules.extbrowser.NbDdeBrowserImpl$URLDisplayer.run(NbDdeBrowserImpl.java:281)
Comment 2 Lukas Hasik 2008-02-04 16:15:21 UTC
reassigning to extbrowser for evaluation
Comment 3 Exceptions Reporter 2008-02-23 04:00:10 UTC
This issue has already 5 duplicates 
Comment 4 Peter Zavadsky 2008-02-29 20:57:57 UTC
I checked the code, the problem is in the ArchiveURLMapper, it creates URI without assuring the string is RFC 2396
compliant.
Comment 5 David Simonek 2008-03-05 11:12:59 UTC
Passing to Radek, please reassign further if I'm wrong.
Comment 6 Peter Zavadsky 2008-03-27 20:54:53 UTC
I don't know why it was passed back without explanation. I provided what I found in the previous comment. The
ArchiveURLMapper creates new instance of URI but doesn't check whether uses valid parameter. In my opinion it should do
the check, and the adjust it accordingly.
Comment 7 Antonin Nebuzelsky 2008-04-15 17:15:31 UTC
Reassigning to new module owner jskrivanek.
Comment 8 Jiri Skrivanek 2008-08-02 13:05:44 UTC
Is it still reproduceable?
Comment 9 Martin Schovanek 2008-08-04 17:21:36 UTC
Still reproducible, may be a space in path problem.
Comment 10 Jiri Skrivanek 2008-08-28 10:26:41 UTC
CompletionDocumentation.getURL doesn't return valid URL. It must not contain spaces. You can use
FileUtil.urlForArchiveOrDir(File entry) to convert File to URL or at least you should call file.toURI().toURL().
Comment 11 Jan Lahoda 2008-08-28 10:54:27 UTC
Not sure why this was reassigned to editor - the CompletionDocumentation is an interface, and so the return value of the
getURL() is sole responsibility of the implementors/SPI clients, in this case:
org.netbeans.editor.ext.html.HTMLCompletionQuery$DocItem
Comment 12 Marek Fukala 2008-08-28 11:00:46 UTC
already fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo