Bug 121255 - Formatting defect(location of "}")
Formatting defect(location of "}")
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
release601_fixes_candidate1 release60...
:
: 126867 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 09:23 UTC by hanbihui
Modified: 2008-02-20 18:02 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hanbihui 2007-11-06 09:23:13 UTC
eg:
public enum Test {
    ID,
}
After "Format",it will be like this:
public enum Test {

    ID,}
I thought the location of "}" would be a new line.
Comment 1 Jiri Prox 2007-11-06 10:34:46 UTC
it's caused by the ',' 
Comment 2 Dusan Balek 2007-11-07 14:43:11 UTC
Fixed.

Checking in Reformatter.java;
/cvs/java/source/src/org/netbeans/modules/java/source/save/Reformatter.java,v  <--  Reformatter.java
new revision: 1.43; previous revision: 1.42
done
Comment 3 Jiri Prox 2008-01-31 10:38:41 UTC
verified 

Product Version: NetBeans IDE Dev (Build 20080131063200)
Java: 1.6.0_05-ea; Java HotSpot(TM) Client VM 1.6.0_05-ea-b06
Comment 4 Jiri Prox 2008-02-07 07:34:30 UTC
*** Issue 126867 has been marked as a duplicate of this issue. ***
Comment 5 Karthikeyan Rajeswaran 2008-02-11 03:02:26 UTC
The fix has been ported into the release601_fixes branch.

Checking in Reformatter.java;
/cvs/java/source/src/org/netbeans/modules/java/source/save/Attic/Reformatter.java,v  <--  Reformatter.java
new revision: 1.41.2.1.4.1; previous revision: 1.41.2.1
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo