Bug 121252 - Module system prefere module in userdir with smaller spec ver
Module system prefere module in userdir with smaller spec ver
Status: RESOLVED DUPLICATE of bug 113341
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 08:28 UTC by pzajac
Modified: 2008-12-22 10:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2007-11-06 08:28:52 UTC
Steps to reproduce:
1) Create module A with specification version 1.1
2) Update version of the module A via AUC to userdir
3) Update version of the module A in install dir

The version in userdir is still used.
Comment 1 Jesse Glick 2007-11-06 09:47:37 UTC
See discussion in issue #113341 about selection of a module to load when it exists in multiple clusters (the userdir
being a special case of a cluster here).

In this case, AU should have updated the module to the install dir to begin with, assuming it was initially there. If it
is failing to do so, please file a bug in autoupdate.

*** This issue has been marked as a duplicate of 113341 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo