Bug 121195 - NullPointerException at org.netbeans.modules.visualweb.dataconnectivity.utils.SampleDatabaseCreator.extractSampleDatabase
NullPointerException at org.netbeans.modules.visualweb.dataconnectivity.utils...
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
All All
: P3 (vote)
: 6.x
Assigned To: John Baker
issues@obsolete
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, release601_fixes_c...
:
: 122010 (view as bug list)
Depends on: 119883
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 15:53 UTC by Karol Harezlak
Modified: 2008-03-20 18:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.19 KB, text/plain)
2007-11-05 15:53 UTC, Karol Harezlak
Details
stacktrace (1.19 KB, text/plain)
2007-11-05 15:57 UTC, Karol Harezlak
Details
stacktrace (1.27 KB, text/plain)
2007-11-15 14:21 UTC, simtec
Details
stacktrace (1.27 KB, text/plain)
2007-11-20 16:58 UTC, marcopar
Details
stacktrace (1.27 KB, text/plain)
2007-11-20 17:05 UTC, marcopar
Details
stacktrace (1.27 KB, text/plain)
2007-11-23 17:42 UTC, gekkothelizard
Details
stacktrace (1.27 KB, text/plain)
2007-11-24 04:48 UTC, simtec
Details
stacktrace (1.27 KB, text/plain)
2007-11-26 12:15 UTC, javydreamercsw
Details
stacktrace (1.27 KB, text/plain)
2007-11-26 12:15 UTC, javydreamercsw
Details
stacktrace (1.27 KB, text/plain)
2007-12-02 13:03 UTC, gekkothelizard
Details
stacktrace (1.27 KB, text/plain)
2007-12-04 20:55 UTC, gmag
Details
stacktrace (1.27 KB, text/plain)
2007-12-17 15:29 UTC, excellion
Details
stacktrace (1.19 KB, text/plain)
2007-12-21 21:26 UTC, Torbjorn Norbye
Details
stacktrace (1.27 KB, text/plain)
2007-12-21 22:44 UTC, guerra
Details
stacktrace (1.27 KB, text/plain)
2007-12-27 12:12 UTC, michelmaquino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Harezlak 2007-11-05 15:53:50 UTC
Build: NetBeans IDE Dev (Build 071031)
VM: Java HotSpot(TM) Client VM, 1.5.0_12-b04
OS: Linux, 2.6.20-16-generic, i386

User Comments:
Comment 1 Karol Harezlak 2007-11-05 15:53:58 UTC
Created attachment 52529 [details]
stacktrace
Comment 2 Karol Harezlak 2007-11-05 15:57:09 UTC
Build: NetBeans IDE Dev (Build 071031)
VM: Java HotSpot(TM) Client VM, 1.5.0_12-b04
OS: Linux, 2.6.20-16-generic, i386

User Comments: 
Comment 3 Karol Harezlak 2007-11-05 15:57:12 UTC
Created attachment 52531 [details]
stacktrace
Comment 4 John Baker 2007-11-05 16:47:28 UTC
Same as 121169

*** This issue has been marked as a duplicate of 121169 ***
Comment 5 John Baker 2007-11-05 17:05:05 UTC
my mistake, not a duplicate
Comment 6 John Baker 2007-11-05 17:07:45 UTC
There is some problem determining the system home.

Please attach messages.log
what is the system home set to ?

Comment 7 John Baker 2007-11-05 17:08:13 UTC
need more info from the user
Comment 8 simtec 2007-11-15 14:21:36 UTC
Build: NetBeans IDE 6.0 RC1 (Build 200711131200)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Linux, 2.6.22-14-generic, i386

User Comments: 
Exception thrown at start-up
Comment 9 simtec 2007-11-15 14:21:39 UTC
Created attachment 53044 [details]
stacktrace
Comment 10 John Baker 2007-11-15 16:53:57 UTC
Where is the NetBeans installation directory?
UNC path ?
Comment 11 marcopar 2007-11-20 16:58:34 UTC
Build: NetBeans IDE 6.0 RC1 (Build 200711131200)
VM: Java HotSpot(TM) Client VM, 1.6.0_01-b06
OS: Linux, 2.6.22-2-k7, i386

User Comments: 
first startup of RC1 importing setting from 5.5
Comment 12 marcopar 2007-11-20 16:58:38 UTC
Created attachment 53258 [details]
stacktrace
Comment 13 marcopar 2007-11-20 17:05:27 UTC
Build: NetBeans IDE 6.0 RC1 (Build 200711131200)
VM: Java HotSpot(TM) Client VM, 1.6.0_01-b06
OS: Linux, 2.6.22-2-k7, i386

User Comments: 
second startup. it seems to be systematic
Comment 14 marcopar 2007-11-20 17:05:31 UTC
Created attachment 53260 [details]
stacktrace
Comment 15 John Baker 2007-11-20 19:57:54 UTC
Please attach messages.log
what is the system home set to ?

Comment 16 gekkothelizard 2007-11-23 17:42:40 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
This happens all the time I start the IDE.
Comment 17 gekkothelizard 2007-11-23 17:42:43 UTC
Created attachment 53419 [details]
stacktrace
Comment 18 John Baker 2007-11-24 00:01:06 UTC
Please attach messages.log

Comment 19 simtec 2007-11-24 04:48:25 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Linux, 2.6.22-14-generic, i386

User Comments: 
Red error icon shows up after start-up
Comment 20 simtec 2007-11-24 04:48:28 UTC
Created attachment 53432 [details]
stacktrace
Comment 21 javydreamercsw 2007-11-26 12:15:13 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows 2000, 5.0, x86

User Comments: 
Comment 22 javydreamercsw 2007-11-26 12:15:20 UTC
Created attachment 53481 [details]
stacktrace
Comment 23 javydreamercsw 2007-11-26 12:15:48 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows 2000, 5.0, x86

User Comments: 
Comment 24 javydreamercsw 2007-11-26 12:15:53 UTC
Created attachment 53482 [details]
stacktrace
Comment 25 John Baker 2007-11-27 01:53:07 UTC
Most likely cause is the .netbeans-derby folder had not been created.
(.netbeans-derby folder is created in the Home directory at IDE startup by the db module and this folder is the default
folder used to store Derby databases created by the IDE.)

To change this folder, from the main menu, choose Tools->Java DB database->Settings and change the Database location.

There may be another bug since .netbeans-derby should always get created.

Partial fix is to throw a FileNotFoundException if .netbeans-derby does not exist.
Note, FileUtil.toFileObject(systemHomeFile); will return null if systemHomeFile does not exist.
/**
     * Converts a disk file to a matching file object.
     * This is the inverse operation of {@link #toFile}.
     * <p class="nonnormative">
     * If you are running with the MasterFS module enabled, that will guarantee
     * that this method never returns null for a file which exists on disk.
     * </p>
     * @param file a disk file (may or may not exist). This file
     * must be {@link #normalizeFile normalized}.
     * @return a corresponding file object, or null if the file does not exist
     *         or there is no {@link URLMapper} available to convert it
     * @since 4.29
     */
Comment 26 John Baker 2007-11-27 02:29:37 UTC
Fixed in visualweb.

Completely fix once 119883 is fixed

Checking in visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/utils/Bundle.properties;
/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/utils/Bundle.properties,v  <-- 
Bundle.properties
new revision: 1.4; previous revision: 1.3
done
Checking in visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/utils/SampleDatabaseCreator.java;
/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/utils/SampleDatabaseCreator.java,v 
<--  SampleDatabaseCreator.jav
a
new revision: 1.5; previous revision: 1.4
done
Comment 27 John Baker 2007-11-27 18:03:56 UTC
Fixed on the visualweb side
Comment 28 John Baker 2007-11-27 21:03:18 UTC
*** Issue 122010 has been marked as a duplicate of this issue. ***
Comment 29 gekkothelizard 2007-12-02 13:03:25 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
Started NB
Comment 30 gekkothelizard 2007-12-02 13:03:28 UTC
Created attachment 53756 [details]
stacktrace
Comment 31 gmag 2007-12-04 20:55:47 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
Comment 32 gmag 2007-12-04 20:55:50 UTC
Created attachment 53878 [details]
stacktrace
Comment 33 excellion 2007-12-17 15:29:44 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
Comment 34 excellion 2007-12-17 15:29:52 UTC
Created attachment 54323 [details]
stacktrace
Comment 35 Torbjorn Norbye 2007-12-21 21:25:52 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.5.0_13-121
OS: Mac OS X, 10.4.11, i386

User Comments: 
After installing patch1, I get this exception on every startup!
Comment 36 Torbjorn Norbye 2007-12-21 21:26:00 UTC
Created attachment 54457 [details]
stacktrace
Comment 37 guerra 2007-12-21 22:44:11 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
Just start the IDE and the error welcomes me !
Comment 38 guerra 2007-12-21 22:44:18 UTC
Created attachment 54459 [details]
stacktrace
Comment 39 michelmaquino 2007-12-27 12:12:52 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Linux, 2.6.18.1-slh-up-2, i386

User Comments: 
Deleted sample java db directory.
Comment 40 michelmaquino 2007-12-27 12:12:57 UTC
Created attachment 54524 [details]
stacktrace
Comment 41 John Baker 2008-01-14 01:12:53 UTC
Should be fixed now
Comment 42 Exceptions Reporter 2008-02-17 19:51:03 UTC
THIS ISSUE HAS ALREADY 100 DUPLICATES
Comment 43 khu 2008-03-06 17:59:59 UTC
The fix has been ported into the release601_fixes branch
(As mentioned, this is the fix on visualweb)
Checking in Bundle.properties;
/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/utils/Attic/Bundle.properties,v  <--
 Bundle.properties
new revision: 1.3.8.1; previous revision: 1.3
done
Checking in SampleDatabaseCreator.java;
/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/utils/Attic/SampleDatabaseCreator.java,v
 <--  SampleDatabaseCreator.java
new revision: 1.4.8.1; previous revision: 1.4
done
Comment 44 Roman Mostyka 2008-03-11 18:48:59 UTC
Verified on Windows XP, Solaris x86/SPARC, Mac OS X. I don't see NullPointerException, so I mark the issue as VERIFIED.
If somebody else will be able to reproduce it, please reopen this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo