Bug 12102 - Debugger can't be finished.
Debugger can't be finished.
Status: CLOSED FIXED
Product: debugger
Classification: Unclassified
Component: Java
3.x
All All
: P1 (vote)
: 3.x
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-11 08:13 UTC by Jan Stola
Modified: 2003-06-30 17:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thrown exception. (3.54 KB, text/plain)
2001-05-11 08:13 UTC, Jan Stola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Stola 2001-05-11 08:13:07 UTC
Netbeans (build 186)
====================

Steps to reproduce:
-------------------
1. Debug examples.advanced.MemoryView.
2. Press the Close button on the MemoryView.
3. NPE will be thrown (see below) and the debugger will not be finished.
4. When the Finish button is pressed NPE is thrown again (see attachment).

java.lang.NullPointerException
at org.netbeans.modules.debugger.jpda.ThreadManager.finish
ThreadManager.java:110)
at org.netbeans.modules.debugger.jpda.JPDADebugger.finishDebugger
(JPDADebugger.java:241)
at org.netbeans.modules.debugger.jpda.JPDADebugger$3.run
(JPDADebugger.java:225)
at org.netbeans.modules.debugger.jpda.util.Operator$1.run
(Operator.java:91)
at java.lang.Thread.run
(Thread.java:484)
Comment 1 Jan Stola 2001-05-11 08:13:48 UTC
Created attachment 1345 [details]
Thrown exception.
Comment 2 Daniel Prusa 2001-05-14 11:35:30 UTC
fixed in main trunk
Comment 3 Jan Stola 2001-05-22 11:24:30 UTC
Verified in Netbeans build 193.
Comment 4 Quality Engineering 2003-06-30 17:36:46 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo