Bug 121018 - Need to quote reserved words when generating SQL
Need to quote reserved words when generating SQL
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Derby
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
: 127065 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 19:12 UTC by David Vancouvering
Modified: 2009-09-18 22:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Vancouvering 2007-11-02 19:12:41 UTC
The tools that generate SQL, like "View Data" and the visual query editor, need to quote reserved words, such as
"PUBLIC" for Java DB.  Otherwise attempts to execute SQL we generate that including identifiers that are reserved words
will fail.

The workaround is for the user to manually quote the identifiers that are reserved words.  I'm hoping this doesn't
happen too often, particularly now that we're no longer quoting when we create objects.
Comment 1 David Vancouvering 2008-03-29 01:33:17 UTC
*** Issue 127065 has been marked as a duplicate of this issue. ***
Comment 2 Jiri Rechtacek 2009-02-10 15:33:06 UTC
Reassigned to new owner.
Comment 3 Jiri Skrivanek 2009-09-15 12:40:04 UTC
Fixed.
core-main #56745543a972
Comment 4 Quality Engineering 2009-09-18 22:20:36 UTC
Integrated into 'main-golden', will be available in build *200909181401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/56745543a972
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #121018 - Quote reserved words when generating SQL.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo