Bug 120908 - Profile Agent on remote system crashes VM when getting snapshot
Profile Agent on remote system crashes VM when getting snapshot
Status: VERIFIED DUPLICATE of bug 62919
Product: profiler
Classification: Unclassified
Component: Base
5.x
All Linux
: P3 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-01 22:55 UTC by joe_h5
Modified: 2007-11-09 22:23 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
JRE 1.5u13 VM error file (29.64 KB, text/plain)
2007-11-01 22:56 UTC, joe_h5
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joe_h5 2007-11-01 22:55:39 UTC
While profiling a remote application running JRE 1.5u13 with Netbeans 5.5.1 Profile Agent library on Linux version 2.6.7
(gcc version 3.2.2) and after Netbeans 5.5.1 Profiler has attached to the target, taking snapshots will crash the target
VM. It may happen on the first, second or third time a snapshot is taken.  I have never been able to get past the third
snapshot.
Comment 1 joe_h5 2007-11-01 22:56:57 UTC
Created attachment 52321 [details]
JRE 1.5u13 VM error file
Comment 2 Jiri Sedlacek 2007-11-02 00:38:30 UTC
Could you please also attach IDE logfile (messages.log) and profiled application log/console output if possible?
Comment 3 Jiri Sedlacek 2007-11-02 00:41:34 UTC
If you are trying to take memory snapshot, then this may be a duplicate of Issue 62919 - if so, please try the 
workaround described in that issue (run profiled application with -Xnoclassgc).
Comment 4 joe_h5 2007-11-02 15:35:23 UTC
Disabling class GC seems to be working.  Not sure why though. As far as I can tell, our Java application is not
dynamically managing classes.

*** This issue has been marked as a duplicate of 62919 ***
Comment 5 Alexander Kouznetsov 2007-11-09 22:23:33 UTC
Verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo