Bug 120691 - IllegalArgumentException when adding an endpoint to External Module
IllegalArgumentException when adding an endpoint to External Module
Status: VERIFIED DUPLICATE of bug 116945
Product: soa
Classification: Unclassified
Component: Composite Application
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: Jun Qian
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 18:31 UTC by jlautz
Modified: 2008-04-09 16:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Messages.log (49.04 KB, application/octet-stream)
2007-10-31 18:37 UTC, jlautz
Details
UI gestures log (155.28 KB, application/octet-stream)
2007-10-31 18:38 UTC, jlautz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jlautz 2007-10-31 18:31:29 UTC
Seen with 
Product Version: NetBeans IDE Dev (Build 200710301200)
Java: 1.5.0_11; Java HotSpot(TM) Client VM 1.5.0_11-b03
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)
Userdir: /Users/lautz/.netbeans/dev

Not sure whether this is related to issue 120681, but I only see the exception if I try to add in new consume and
provide endpoints after encountering the problem described in issue 120681. I do not have exact reproduceable steps, but
will include the messages.log showing an error and the uigestures file.

1. Create a new SynchronousSample sample app.
2. Open SynchronousSampleApplication in the CASA editor.
3. DnD a new External from the palette to the External Mmodule area.
4. Rename the external module by changing the name property in the properties dialog and clicking Close.
5. Using the context menu for the external module, add a consume and provide endpoint.
6. Rename the endpoints. (Doesn't seem to matter.)
7. Save. (This doesn't seem to matter.)
8. Click the Build Project button.

=> The endpoints disappear.

9. Add the provide and consume endpoints again. Click build project. Add a few more consume and provide endpoints.

=> IllegalArgumentException dialog shown.
Comment 1 jlautz 2007-10-31 18:37:24 UTC
Created attachment 52167 [details]
Messages.log
Comment 2 jlautz 2007-10-31 18:38:39 UTC
Created attachment 52168 [details]
UI gestures log
Comment 3 Jun Qian 2007-10-31 23:34:38 UTC
The IllegalArgumentException looks similar to some issue I reported directly from within NetBeans. I can't find that
ticket number now.
Comment 4 Jun Qian 2007-11-01 22:35:07 UTC

*** This issue has been marked as a duplicate of 116945 ***
Comment 5 jlautz 2008-04-09 16:40:40 UTC
Verified fixed with 
Product Version: NetBeans IDE Dev (Build 200804040802) - Java CAPS Enabled
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)
Userdir: /Users/lautz/sierrabuilds/JavaCAPS20080406/.netbeans/caps


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo