Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 120681 - External module endpoints added disappear
External module endpoints added disappear
Status: VERIFIED WORKSFORME
Product: soa
Classification: Unclassified
Component: Composite Application
6.x
PC Solaris
: P2 (vote)
: 6.x
Assigned To: Jun Qian
issues@soa
fix-in-60
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 17:35 UTC by jlautz
Modified: 2008-02-05 22:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jlautz 2007-10-31 17:35:56 UTC
Seen with 
Product Version: NetBeans IDE Dev (Build 200710301200)
Java: 1.5.0_11; Java HotSpot(TM) Client VM 1.5.0_11-b03
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)
Userdir: /Users/lautz/.netbeans/dev

1. Create a new SynchronousSample sample app.
2. Open SynchronousSampleApplication in the CASA editor.
3. DnD a new External from the palette to the External Mmodule area.
4. Rename the external module by changing the name property in the properties dialog and clicking Close.
5. Using the context menu for the external module, add a consume and provide endpoint.
6. Rename the endpoints. (Doesn't seem to matter.)
7. Save. (This doesn't seem to matter.)
8. Click the Build Project button.

=> The endpoints disappear.
Comment 1 jlautz 2007-10-31 17:52:23 UTC
I didn't see any messages in the message.log.
Comment 2 jlautz 2007-10-31 17:56:26 UTC
The endpoints also disappear with a change to source view and back to design view.
Comment 3 jlautz 2007-10-31 18:30:41 UTC
Additional info: it seems like the 2nd or 3rd time I add them and build the project, the endpoints stick around.
Comment 4 Jun Qian 2007-10-31 20:44:19 UTC
Can't reproduce on WinXP. I will try it on a Sun box tomorrow.
Comment 5 jlautz 2007-10-31 21:01:29 UTC
I don't see in on XP either. I've changed it to be Solaris x86 only (I think that's what PC/Solaris means).
Comment 6 Jun Qian 2007-11-02 02:32:26 UTC
I, Jeff and Jason, tried this on a Solaris x86 box (about 40 times) and none of us was able to reproduce the reported
disappearing external endpoints problem.

This is the system we used:

Product Version: NetBeans IDE Dev (Build 20071101185309)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-b05
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)
Userdir: /home/jqian/.netbeans/dev


We did see a different problem though. After the first build, sometimes the casa file doesn't seem to get updated. When
this happened, clicking the build button again always worked.
Comment 7 jlautz 2007-11-02 16:26:25 UTC
I just installed today's kit (including new GF, updated JDK, deleted .netbeans directory), and I can still reproduce the
scenario above. If you want to watch, I'll set up VNC.

Product Version: NetBeans IDE Dev (Build 200711020000)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)
Userdir: /Users/lautz/.netbeans/dev

Comment 8 jlautz 2007-11-02 20:56:25 UTC
Can no longer reproduce with today's kit. I rebooted, deleted .netbeans, tried a variety of things, and cannot make the
EM endpoints disappear. (Although, I did this morning with the same configuration, so this is highly frustrating.)

Jun and I think it might be a timing issue that only shows up with the system in a certain state, that we can't
currently determine.

I will close this as unreproduceable for now. I will reopen if it shows up again.
Comment 9 jlautz 2008-02-05 22:01:26 UTC
Cannot reproduce.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo