Bug 120402 - Failed to obtain snapshot. The profiled application terminated.
Failed to obtain snapshot. The profiled application terminated.
Status: VERIFIED DUPLICATE of bug 62919
Product: profiler
Classification: Unclassified
Component: Base
6.x
Macintosh All
: P3 (vote)
: 6.x
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 19:57 UTC by William Leonard
Modified: 2007-11-09 22:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Leonard 2007-10-29 19:57:07 UTC
I'm working through the HttpUnit case study, as documented here (http://wiki.netbeans.org/wiki/view/HttpUnitCaseStudy),
on a Mac. When I try step 21. Right-click the entry for String and select Take Snapshot and Show Allocation Stack
Traces, a dialog appears: Failed to obtain snapshot. The profiled application terminated. The output window shows the
following:

Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x546d62, *mId = 84
Profiler Agent Warning: dCl = 0x50a430, *dCl = 174837168
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x53a272, *mId = 82
Profiler Agent Warning: dCl = 0x50a4cc, *dCl = 173900736
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x541a32, *mId = -814743470
Profiler Agent Warning: dCl = 0x50a658, *dCl = 177141296
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x541a34, *mId = 5427056
Invalid memory access of location 00000022 eip=9c208b84
Profiler Agent Warning: dCl = 0x50a8b8, *dCl = 178045528
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x543082, *mId = 248512512
Profiler Agent Warning: dCl = 0x521b08, *dCl = 173620912
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x52e594, *mId = 113306216
Profiler Agent Warning: dCl = 0x520dbc, *dCl = 180014888
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x5154f2, *mId = 1832386560
Profiler Agent Warning: dCl = 0x520de0, *dCl = 179691848
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x543084, *mId = 113315536
Profiler Agent Warning: dCl = 0x53973c, *dCl = 179972864
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x52ee72, *mId = 248512512
Profiler Agent Warning: dCl = 0x51ddd0, *dCl = 177491056
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x546d74, *mId = 0
Profiler Agent Warning: dCl = 0x5379b4, *dCl = 179624344
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0x5200d2, *mId = -1318584320
Profiler Agent Warning: dCl = 0x5308b4, *dCl = 177317624
Java Result: 138

This is on: 
java version "1.5.0_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)
Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)

I'm assuming this is a flaw in Apple's JVM implementation, but I thought I'd file the issue regardless.
Comment 1 Jiri Sedlacek 2007-10-30 17:03:12 UTC
Duplicate, please see Issue 62919 for more information & workaround (running profiled app with -Xnoclassgc).

*** This issue has been marked as a duplicate of 62919 ***
Comment 2 Alexander Kouznetsov 2007-11-09 22:22:39 UTC
Verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo