Bug 119861 - [unpack200] Installation stops with error (unpack200 killed by timeout)
[unpack200] Installation stops with error (unpack200 killed by timeout)
Status: RESOLVED WONTFIX
Product: installer
Classification: Unclassified
Component: Code
6.x
All Windows XP
: P3 (vote)
: TBD
Assigned To: issues@installer
issues@installer
: RELNOTE
: 122074 153107 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 07:36 UTC by ernonieminen
Modified: 2009-01-12 22:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Intallation log (39.56 KB, text/plain)
2007-10-24 07:37 UTC, ernonieminen
Details
Process log when installation was freezed (19.20 KB, text/plain)
2007-10-24 11:01 UTC, ernonieminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernonieminen 2007-10-24 07:36:17 UTC
Tryed to install NetBeans 6.0 beta 2 and the installation program ended unexpectedly with the following error in the log:
[2007-10-24 08:52:30.062]: executing command: C:\Program Files\Java\jre1.5.0_11\bin\unpack200.exe C:\Program
Files\NetBeans 6.0 Beta 2\platform7\modules\org-netbeans-modules-editor-mimelookup.jar.pack.gz C:\Program Files\NetBeans
6.0 Beta 2\platform7\modules\org-netbeans-modules-editor-mimelookup.jar, in directory: .
[2007-10-24 09:02:39.515]:     [return]: killed by timeout
[2007-10-24 09:02:39.546]: ... command execution finished
[2007-10-24 09:02:39.546]: org.netbeans.installer.utils.exceptions.InstallationException: Cannot extract installation
data for Base IDE
[2007-10-24 09:02:39.546]: 	at org.netbeans.installer.product.components.Product.install(Product.java:285)
[2007-10-24 09:02:39.546]: 	at
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:144)
[2007-10-24 09:02:39.546]: 	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:120)
[2007-10-24 09:02:39.546]: Caused by: java.io.IOException: Unpack200 finished with error
[2007-10-24 09:02:39.546]: Error code: 2 147 483 647
[2007-10-24 09:02:39.546]: Stdout: 
[2007-10-24 09:02:39.562]: Stderr: 
[2007-10-24 09:02:39.562]: 	at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1092)
[2007-10-24 09:02:39.562]: 	at org.netbeans.installer.utils.FileUtils.extractByList(FileUtils.java:1612)
[2007-10-24 09:02:39.562]: 	at org.netbeans.installer.utils.FileUtils.extractAll(FileUtils.java:1532)
[2007-10-24 09:02:39.562]: 	at org.netbeans.installer.utils.FileUtils.unjar(FileUtils.java:927)
[2007-10-24 09:02:39.562]: 	at org.netbeans.installer.product.components.Product.install(Product.java:275)
Comment 1 ernonieminen 2007-10-24 07:37:36 UTC
Created attachment 51544 [details]
Intallation log
Comment 2 dlipin 2007-10-24 07:57:28 UTC
do you have any antivirus/firewall/monitoring software running?
is this issue reproducible or sporadic? if reproducible then does it occur on the same file each time?

could you please manually run command:
"C:\Program Files\Java\jre1.5.0_11\bin\unpack200.exe" "C:\Program Files\NetBeans 6.0 Beta 2\platform7\modules\org-
netbeans-modules-editor-mimelookup.jar.pack.gz" "C:\Program Files\NetBeans 6.0 Beta 2\platform7\modules\org-netbeans-
modules-editor-mimelookup.jar"
did it take much time execute it?

how much memory and what kind of processor do you have?
Comment 3 ernonieminen 2007-10-24 08:54:56 UTC
Yes, I have Symantec firewall and antivirus. Installation freezes every time at the same file (the first one I guess). I
tryed to turn of both the firewall and the antivirus, did not help. I runned the command manually. This is odd: at the
first installation log it says it is trying to extract file org-netbeans-modules-editor-mimelookup.jar.pack.gz. When
running again it is trying to extract file org-netbeans-modules-editor-mimelookup-impl.jar.pack.gz (notice the -impl).
Every time there has been gz-file named org-netbeans-modules-editor-mimelookup-impl.jar.pack.gz on my hard drive and it
has extracted it correctly, but the installation program does not notice that when the file has been extracted.
Extraction process takes less than a second to complete, when running manually. I have 2 GB of memory and Intel Core 2
processor (T5600 1,83GHz).
Comment 4 dlipin 2007-10-24 09:05:19 UTC
could you please make a list of the running processes ?
C:\WINDOWS\system32\tasklist.exe /V /FO TABLE > log.txt

could you please also try whether the issue is reproducible on the latest JDK5 (1.5.0_13) and JDK6 (1.6.0_03) ?

thanks in advance,
dmitry
Comment 5 dlipin 2007-10-24 09:18:57 UTC
Marek,

if I am not mistaken we had similar problems (unpack200 freezes) in the past.
Don`t you remember what was the issue?

Thanks,
Dmitry
Comment 7 mslama 2007-10-24 10:14:56 UTC
No I do not about any other issue or place we use unpack200.exe.
Comment 8 ernonieminen 2007-10-24 11:00:36 UTC
Now I have tested installation with different JDK versions. With 1.5.0_13 version installation freezed after 2 percent
was completed. With JDK 1.6.0_3 installation went through without problems. When 1.5.x version of the JDK was used I
noticed that the unpack200.exe stayed in the memory doing nothing. Log of the running processes when the installation
program is freezed is attached. So I think the easiest solution here is to install a JDK with version 1.6.x.
Comment 9 ernonieminen 2007-10-24 11:01:34 UTC
Created attachment 51561 [details]
Process log when installation was freezed
Comment 10 dlipin 2007-10-29 13:05:27 UTC
ernonieminen,

yes, JDK5 can be the issue but afaik no serios issues were fixed in unpack200 between JDK5 and JDK6.

If you run Windows in safe mode and the installer still hangs with using JDK5 then I could definitely say that it is 
the issue of JDK5 and JDK6 is the only way to use on the such systems where installer hangs with JDK5.
Otherwise it is the environment issue and can be identified.

I would very appreciate you if you could turn off unnecessary programs/services (the more - the better) - in the best 
case, one be one - and try installer again and again.
If the installer stops hanging with exiting certain program/service - please let us know.
As far as I see, there is a lot of programs running at the moment of installation (according to the log) so most 
probably one of them makes the unpack200 hanging.

We will add this info into release notes if you find out that problematic program/service so that other users would 
know how to workaround the same issue.

Thanks in advance,
Dmitry
Comment 11 ernonieminen 2007-11-01 11:19:48 UTC
Good news. I managed to find the service that causes the unpack200.exe to hang with JDK1.5. It is c:\program
files\common files\logitech\lvmvfm\LVPrcSrv.exe. (Display name: Logitech Process Monitor, Description: Webcam Effects
Helper.) I don't know what this exactly does, but I have verified several times that when this service is running the
unpack200 hangs. When it is stopped the NetBeans installation works like a charm.
Comment 12 dlipin 2007-11-01 11:43:51 UTC
ernoniemine,

see the Issue 117334.
In that case this Logitech service force unpack200 return unbelivable error code -1073741801.

After stopping the service all the issues are gone.
Glad to hear that is the core of the issue is the same..

We can`t fix the issue but we`ll add it to release notes.

Irina,
please make a new record in the release notes with refer to issues 117334 and 119861 with the similar meaning:
If you have Logitech Process Monitor (Webcam Effects Helper) (LVPrcSrv.exe) running, switch it off before installation/
uninstallation.
It is also worth to mention in RelNotes to disable and firewall/antivirus/antispyware software before installation 
since they all can cause inpredictable effects as well.


Many thanks for you help,
Dmitry
 
Comment 13 dlipin 2007-11-16 08:09:46 UTC
*** Issue 122074 has been marked as a duplicate of this issue. ***
Comment 14 Irina Filippova 2007-11-20 05:38:55 UTC
The issue is added to RC2 and FCS Release Notes.

A note about switching off firewall/antivirus/antispyware software is added to the installation instructions.

Thanks,
Irina
Comment 15 dlipin 2008-11-13 10:18:16 UTC
*** Issue 153107 has been marked as a duplicate of this issue. ***
Comment 16 jbfaden 2009-01-12 22:23:30 UTC
I see this on Fedora Redhat 8 using Sun's jdk1.5, which doesn't have .../jre/bin/unpack200.  jdk1.6 appears to have it
and it looks like it is going to work.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo