Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 119569 - NPE at sun.swing.table.DefaultTableCellHeaderRenderer.getColumnSortOrder
NPE at sun.swing.table.DefaultTableCellHeaderRenderer.getColumnSortOrder
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All Windows Vista
: P1 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, fixed-in-6.0.1
: RELNOTE
: 119599 122882 123929 125609 125652 125904 126138 126163 129596 132994 134939 138561 153007 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 06:47 UTC by chrischr
Modified: 2008-12-22 11:59 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.09 KB, text/plain)
2007-10-21 06:47 UTC, chrischr
Details
log file with the null pointers (37.98 KB, application/octet-stream)
2007-11-02 22:49 UTC, navneet
Details
stacktrace (4.16 KB, text/plain)
2007-12-05 16:33 UTC, luano
Details
patch (1.08 KB, patch)
2008-01-21 15:59 UTC, Stanislav Aubrecht
Details | Diff
stacktrace (4.16 KB, text/plain)
2008-01-27 17:28 UTC, spac
Details
stacktrace (4.16 KB, text/plain)
2008-01-27 19:15 UTC, jatco
Details
stacktrace (3.48 KB, text/plain)
2008-01-27 19:42 UTC, gardnervh
Details
stacktrace (4.16 KB, text/plain)
2008-01-27 21:27 UTC, kitfox
Details
stacktrace (5.19 KB, text/plain)
2008-01-27 21:28 UTC, kitfox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chrischr 2007-10-21 06:47:25 UTC
Build: NetBeans IDE 6.0 Beta 1 (Build 200709141330)
VM: Java HotSpot(TM) Client VM, 1.6.0_05-ea-b05
OS: Windows Vista, 6.0, x86

User Comments: 
trying to open a project
Comment 1 chrischr 2007-10-21 06:47:28 UTC
Created attachment 51372 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2007-10-22 08:49:17 UTC
dafe, pls try to reproduce on win vista, thanks
Comment 3 David Simonek 2007-10-24 15:07:54 UTC
I'm sorry, but I'm unable to reproduce, opening a project forks like a charm on my Vista and JDK 1.6.0_05 build 4 and
build 5. If the bug reappears, please reopen, but with detailed steps how to reproduce the issue, thanks.

Btw does anybody know where to get sources for sun.swing.table.DefaultTableCellHeaderRenderer?
Comment 4 navneet 2007-11-02 22:45:57 UTC
Here is what I did when i saw this problem: (6.0Beta2)
1. Opened the project. 
2. Compile and build in I have 1.6.0_03
3. Close the project and IDE
3. upgrade to I have 1.6.0_05-b05
4. open the ide and project
5. Start debuging
6. Minimize all the output and debugging windows so that they are docked
7. Stop debugging.
8. Start debugging.
9. open the output window and pin it. 
10. open the Local Variables window. You will see the error flashing at the bottom of the window.

Comment 5 navneet 2007-11-02 22:49:48 UTC
Created attachment 52423 [details]
log file with the null pointers
Comment 6 navneet 2007-11-22 20:58:34 UTC
raising the priority on this since it does not allow me to debug my applications. The watch windows are all blank
spaces. Has to be fixed for 6.0. I have tested this with 1.6.0_10-ea-b07 too with 6.0RC2. Same results. 
Comment 7 Stanislav Aubrecht 2007-11-23 07:33:30 UTC
sure it has to be fixed, but until 1.6.0_10 is released officially it's still a P3
Comment 8 _ alexlamsl 2007-11-23 17:20:22 UTC
When reporting a stacktrace to netbeans.org, I am pointed to this issue.

Steps to reproduce my problem:
1) Tools --> Options
2) Advanced Options


Product Version: NetBeans IDE Dev (Build 200711230000)
Java: 1.6.0_10-ea; Java HotSpot(TM) Client VM 1.6.0_10-ea-b07
System: Windows Vista version 6.0 running on x86; Cp1252; en_GB (nb)
Comment 9 Marian Mirilovic 2007-11-25 18:19:08 UTC
24 reports so far, some of them are reported agaist trunk (but not all ;( )
Comment 10 Tomas Pavek 2007-11-28 20:36:42 UTC
So is this a JDK bug? If yes, we should make sure it is reported and fixed (before the JDK update is released).
Comment 11 Stanislav Aubrecht 2007-11-30 10:18:36 UTC
it doesn't have to be jdk bug, swingset demo runs fine under jdk1.6u5 (i think)

dafe, can you pls try again on your vista machine? thanks
Comment 12 lmalvent 2007-11-30 14:31:40 UTC
FYI

This are the tests I have performed on Windows Vista Business:

1/ NetBeans 6.0 RC2 running on JDK 1.6.0_10-ea-b07

   SwingSet2 running on JDK 1.6.0_03-b05 ------> debugger doesn't work: NullPointerException
   SwingSet2 running on JDK 1.6.0_10-ea-b07 ---> debugger doesn't work: NullPointerException

2/ NetBeans 6.0 RC2 running on JDK 1.6.0_03-b05

   SwingSet2 running on JDK 1.6.0_03-b05 ------> debugger works fine
   SwingSet2 running on JDK 1.6.0_10-ea-b07 ---> debugger works fine

So it is definitely related to the JDK version NetBeans 6.0 RC2 is running on.
Comment 13 _ gtzabari 2007-12-03 02:36:16 UTC
I can reproduce this issue 100% of the time:

1) Windows Vista 64-bit
2) JDK6 64-bit: "build 1.6.0_10-ea-b07"
3) Tools -> Options -> Advanced -> Netbeans throws the exception
Comment 14 luano 2007-12-05 16:32:52 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_05-ea-b04
OS: Windows Vista, 6.0, x86

User Comments: 
None of the TopComponents containing a table are rendered. This includes the Call Stack, Breakpoints and Local Variables view within the debugger.

Other tables also seem to be affected.
Comment 15 luano 2007-12-05 16:33:00 UTC
Created attachment 53907 [details]
stacktrace
Comment 16 Stanislav Aubrecht 2007-12-10 09:53:08 UTC
see also this: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6599742
Comment 17 luano 2007-12-10 16:55:14 UTC
Problem occurs with jdk1.6.0_05 on Vista but not with jdk1.6.0_02.

Reverting to earlier JDK resolves the issue.
Comment 18 Stanislav Aubrecht 2007-12-13 14:24:22 UTC
*** Issue 123929 has been marked as a duplicate of this issue. ***
Comment 19 Jaromir Uhrik 2007-12-13 14:25:55 UTC
It is reproducible in jdk1.6.0_10 - b08
Comment 20 David Konecny 2007-12-13 15:20:15 UTC
Due to this problem CVS Search History is unusable (issue 123929). IMO this is P2. Could we worked around JDK problem
somehow?
Comment 21 Stanislav Aubrecht 2007-12-13 15:35:21 UTC
fixed

Checking in TableSheetCell.java;
/cvs/openide/explorer/src/org/openide/explorer/view/TableSheetCell.java,v  <--  TableSheetCell.java
new revision: 1.11; previous revision: 1.10
Comment 22 Stanislav Aubrecht 2007-12-14 10:28:39 UTC
*** Issue 122882 has been marked as a duplicate of this issue. ***
Comment 23 Stanislav Aubrecht 2007-12-14 10:42:32 UTC
*** Issue 119599 has been marked as a duplicate of this issue. ***
Comment 24 tsromney 2008-01-18 20:08:29 UTC
Can we get this patched into Netbeans 6.0.  This is causing real headaches
Comment 25 navneet 2008-01-18 20:19:48 UTC
This is happening with JDK 1.6 update 4 too. This is a release from Sun so it now needs to be fixed. We don't see this
in JDK 1.6 update 3.

Is this a regression in the JDK or was there a fix for a JDK bug that's now gone ?

I would raise the priority to 1 on this one since it stops me from working with the latest JDK release.

Can we get a Netbeans update ?
Comment 26 Lukas Hasik 2008-01-21 08:56:42 UTC
Are we able to provide it in Patch for 6.0(.1) users? IMO, it is worth to when it was reported 198 times (see URL link)
Comment 27 Marian Mirilovic 2008-01-21 11:50:22 UTC
Agreed, I think this has to be integrated in 6.0.1 patch 1
Comment 28 Stanislav Aubrecht 2008-01-21 15:58:30 UTC
this is will be merged into netbeans 6.0.1, dafe pls review
Comment 29 Stanislav Aubrecht 2008-01-21 15:59:44 UTC
Created attachment 55336 [details]
patch
Comment 30 David Simonek 2008-01-21 16:03:41 UTC
Patch reviewed, OK, simple and very low risk.
Comment 31 Lukas Hasik 2008-01-21 16:05:14 UTC
*** Issue 125652 has been marked as a duplicate of this issue. ***
Comment 32 Stanislav Aubrecht 2008-01-21 16:05:52 UTC
merged into release60 branch

/cvs/openide/explorer/src/org/openide/explorer/view/TableSheetCell.java,v  <--  TableSheetCell.java
new revision: 1.10.6.1; previous revision: 1.10
Comment 33 Lukas Hasik 2008-01-21 16:09:06 UTC
adding status whiteboard to somehow mark that the issue was fixed also for 6.0.1 release
Comment 34 Karthikeyan Rajeswaran 2008-01-21 18:12:40 UTC
Removing the keyword release601_fixes_candidate1 (which was mistakenly added) since the issue is fixed in 6.0.1 itself.
Comment 35 Lukas Hasik 2008-01-22 10:03:35 UTC
verified in 6.0.1 build and with 6.0FCS update with 6.0.1 modules that the NPE doesn't appear when opening debugger 
view or Advanced Options. 
Tested on Windows Vista version 6.0 running on x86;
with Java: 1.6.0_10-ea; Java HotSpot(TM) Client VM 1.6.0_10-ea-b08
and with Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19 

The issue was reproducible without the patch.
Comment 36 Patrick Keegan 2008-01-23 18:55:23 UTC
In user terms, what happens here? Is this attempted summary correct?

"When running on Windows Vista and JDK 6 Update 4, it is impossible to work with the debugger windows and the Options
window Advanced Options view"?

Comment 37 Lukas Hasik 2008-01-24 08:18:38 UTC
What happens? 
On Windows Vista with jdk1.6.0_4/5/10 the NB 6.0 throws NPE when the IDE displays any TreeTableView then NPE appears.
This issue has been fixed in trunk (6.1) already. The fix will be distributed to 6.0 user through update center together
with the 6.0.1 release very soon.
HTH
Comment 38 Stanislav Aubrecht 2008-01-24 17:04:41 UTC
the bug was fixed in 6.1M1, so, august, don't change the target milestone pls
Comment 39 tofarr 2008-01-25 10:15:24 UTC
Here is another temporary work around: Switch theme to windows classic. (Soooo Ugly!) I tried turning off Aero, to no
avail, and then tried this and hey presto. (If you can live with the retro look and feel until a patch is released
(Hopefully soon!)

I think this is a drastic step, and this needs to be cleared up ASAP - Issues like this will make non loyal users run
away as fast as they can (ie: If netbeans was something that I had never used before and this was my first experience
with it, then it would not still be installed on my machine. A lot of new PCs are running vista, and issues like this
create a very poor first impression.
Comment 40 Marian Mirilovic 2008-01-25 10:27:33 UTC
So the fix of this issue is going to be released next week (31/Jan) as a part of NB 6.0.1 patch release (available as
update for all NB 6.0 users as well as separate release on download page). 

Workarounds are:
- downgrade your JDK to JDK6u3 version
- change L&F to windows classic


Comment 41 Patrick Keegan 2008-01-25 15:54:06 UTC
Lukas, Marian, can you sanity check this text?

Issue #119569: NPE at sun.swing.table.DefaultTableCellHeaderRenderer.getColumnSortOrder

    Description: When running on Windows Vista and JDK 6 Update 4 (also Update 5 and Update 10), the IDE throws a
NullPointerException when displaying any TreeTableView component, such as in debugger windows and the Advanced view of
the Options window.

    Workaround: Do one of the following:

        * Wait for the fix to be in available in the Plugins manager. The fix is due January 31, 2008.
        * Downgrade the installation that the IDE runs on to JDK 6 Update 3. You can set the JDK in the
NetBeans-Installationetc/netbeans.conf file.
        * Switch your system to use the Windows Classic theme. You can do so in the Personalization section of the
Control Panel of your system.
Comment 42 johnswann 2008-01-25 21:50:30 UTC
This bug is NOT fixed in the current released version of Netbeans (Build 200711261600).

When I reported this problem I got an automated response telling me it was fixed and that I should installed the most
recent version.

I installed this version (Build 200711261600) a total of 3 times and the problem persisted.

The problem was resolved when I installed the unreleased 6.1 (Build 20080122000).
Comment 43 Lukas Hasik 2008-01-27 12:59:29 UTC
johnswann, you are right. This issue wasn't fixed in 200711261600 == NetBeans 6.0. It cannot be, the release is out
already. We will deliver the fix for 6.0 users through the Update Center and Plugins Manager in IDE. The patch will be
released/published together with NetBeans 6.0.1 release (around 1/31). 
The fix is available in the development/trunk (6.1) builds for while.

The "Target Milestone" field of the issue report says where the fix can be find. Or you can read the comments for more
details.


I'm closing this issue as fixed again. Thank you for understanding. Please wait for the patch with the fix or update to
development version of the IDE (not recommended for production...)
Comment 44 spac 2008-01-27 17:28:16 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows Vista, 6.0, x86

User Comments: 
I want debug my Java Application. But LocalVariables view don`t contain anz informations...
Comment 45 spac 2008-01-27 17:28:20 UTC
Created attachment 55623 [details]
stacktrace
Comment 46 jatco 2008-01-27 19:15:31 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows Vista, 6.0, x86

User Comments: 
Comment 47 jatco 2008-01-27 19:15:35 UTC
Created attachment 55627 [details]
stacktrace
Comment 48 gardnervh 2008-01-27 19:42:20 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows Vista, 6.0, x86

User Comments: 
Pressed the button to show the advanced version of the tools, options dialog
Comment 49 gardnervh 2008-01-27 19:42:24 UTC
Created attachment 55628 [details]
stacktrace
Comment 50 kitfox 2008-01-27 21:27:25 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows Vista, 6.0, x86

User Comments: 
Attempted to view local variables by slecting the tab of that window while debugging.
Comment 51 kitfox 2008-01-27 21:27:30 UTC
Created attachment 55629 [details]
stacktrace
Comment 52 kitfox 2008-01-27 21:28:12 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows Vista, 6.0, x86

User Comments: 
Comment 53 kitfox 2008-01-27 21:28:15 UTC
Created attachment 55630 [details]
stacktrace
Comment 54 Lukas Hasik 2008-01-28 08:54:03 UTC
closing as verified again
Comment 55 Tomas Stupka 2008-01-28 11:19:15 UTC
*** Issue 125904 has been marked as a duplicate of this issue. ***
Comment 56 Stanislav Aubrecht 2008-01-29 10:39:33 UTC
*** Issue 126138 has been marked as a duplicate of this issue. ***
Comment 57 Lukas Hasik 2008-02-01 12:58:47 UTC
*** Issue 126163 has been marked as a duplicate of this issue. ***
Comment 58 Lukas Hasik 2008-02-05 09:02:34 UTC
*** Issue 125609 has been marked as a duplicate of this issue. ***
Comment 59 Exceptions Reporter 2008-02-06 07:30:13 UTC
THIS ISSUE HAS ALREADY 5 DUPLICATES
Comment 60 Jana Maleckova 2008-03-10 10:54:41 UTC
*** Issue 129596 has been marked as a duplicate of this issue. ***
Comment 61 Lukas Hasik 2008-05-13 17:07:54 UTC
*** Issue 134939 has been marked as a duplicate of this issue. ***
Comment 62 Lukas Hasik 2008-06-30 09:37:04 UTC
*** Issue 138561 has been marked as a duplicate of this issue. ***
Comment 63 Lukas Hasik 2008-07-25 11:21:21 UTC
*** Issue 132994 has been marked as a duplicate of this issue. ***
Comment 64 Jiri Prox 2008-11-12 09:48:17 UTC
*** Issue 153007 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo