Bug 118772 - It should be possible to disable the JUnit Window
It should be possible to disable the JUnit Window
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: JUnit
6.x
All All
: P3 (vote)
: 7.2
Assigned To: Theofanis Oikonomou
junit-issues@java
: PLAN
: 136196 165881 170955 (view as bug list)
Depends on: 210554 211104
Blocks: 210149
  Show dependency treegraph
 
Reported: 2007-10-13 00:23 UTC by vieiro
Modified: 2012-04-13 16:13 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vieiro 2007-10-13 00:23:59 UTC
The JUnit Test Results window should be optional, I find it annoying to see it appear (and make itself visible) whenever
a JUnit test is run.

I think I'm not the only one suggesting it (see 
"JUnit results window often reopens itself" - http://www.netbeans.org/issues/show_bug.cgi?id=76587, or "Floating window
wars between JU output & all others windows" - http://www.netbeans.org/issues/show_bug.cgi?id=59883).
Comment 1 Marian Petras 2007-10-13 20:14:34 UTC
For release 6.0, this will not change (UI if frozen, with the exception of changes necessary for fixing of serious
bugs). The subsequent comments will be about changes suggested for the future release.
Comment 2 Marian Petras 2007-10-13 20:15:56 UTC
This could be implemented in the JUnit module's settings. There could be e.g. the following options:

    When the JUnit results window should be displayed:

    a) until a failure is detected

       ( )  display the results window as soon as tests start
       (o)  display the results window upon end of the testing session
       ( )  do not display the results window

    b) in case there is a failure detected

       ( ) do not change the behaviour
       ( ) display the JUnit results window immediately
       ( ) display the JUnit results window upon end of the testing session
       ( ) interrupt the testing session and display the JUnit results window

(Some options from the second set of radio-buttons could be disabled, depending on the current selection in the first
set of radio-buttons.)
Comment 3 vieiro 2008-08-19 21:20:31 UTC
Any chances to have this done with release 6.5?
Comment 4 Marian Petras 2008-08-20 11:40:51 UTC
Almost no chance, sorry.
Comment 5 jrojcek 2008-08-26 14:03:56 UTC
The JUnit window should open only if there's a test that fails. Specifically:

- if the user runs tests, the global progress indication shows that tests are running (no window open yet).
- if tests finish successfully, the progress disappears (no window open).
- if a test fails, the window is open.

I hope this would work for majority of users. No option is necessary IMO.
Comment 6 Alexei Mokeev 2009-03-27 08:06:43 UTC
*** Issue 136196 has been marked as a duplicate of this issue. ***
Comment 7 Alexei Mokeev 2009-03-27 08:08:54 UTC
From lstroud (136196)
>I run a lot of unit tests (many times the wrong way, when I want to see some output). The junit result panel always pops
>up and annoyingly takes the focus. I would like to be able to configure the junit result panel to not show or stay
>hidden.  Ideally, you would be able to minimize it, it stay minimized, and see a status bar update or change in the
>color of the bottom bar button to indicate results. 
Comment 8 vieiro 2009-08-26 19:12:41 UTC
The JUnit pop-up window thinks it's the center of the world, and keeps on appearing in the middle of my face whenever I
run JUnit tests. And keeps on appearing when I debug JUnit tests (hiding the debugger).

I don't want to see it at all. I hate it. It's not for me. It gets in my way. I get upset whenever I see it.

Would it be possible to disable it somehow? Would it be possible to work on this issue in the NetDev program or
something? I'd love getting rid of it.
Comment 9 pribyl 2009-08-27 09:53:51 UTC
*** Issue 170955 has been marked as a duplicate of this issue. ***
Comment 10 Ondrej Langr 2009-09-03 12:34:47 UTC
Based on number of duplicates and the description this seems more like a bug then an enhancement. 

Jrojcek has suggested a viable solution, can we try to get this into 6.8?
Comment 11 Victor Vasilyev 2010-04-15 18:19:06 UTC
Unfortunately, it won't be fixed even in 6.9
Comment 12 Victor Vasilyev 2010-04-15 18:30:51 UTC
*** Bug 165881 has been marked as a duplicate of this bug. ***
Comment 13 Alexei Mokeev 2010-07-26 13:16:06 UTC
We should introduce options regarding when to open test results window.
Comment 14 Theofanis Oikonomou 2012-03-29 09:46:19 UTC
Fixed: http://hg.netbeans.org/core-main/rev/218501f98558

The proposal from comment 5 is implemented and now the test results window is only opened when there is an error or failure
Comment 15 Jesse Glick 2012-04-13 16:13:21 UTC
BTW another API to experiment with is TopComponent.requestAttention. If called, it will make the window header blink a couple of times and then change its background to orange until user activates it (description courtesy of saubrecht). Used for windows that the user probably wants to look at sooner or later but without disrupting current activity. TRW with failures is a possible candidate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo