Bug 118512 - Deadlock of IDE
Deadlock of IDE
Product: javame
Classification: Unclassified
Component: Visual Designer
All All
: P2 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
Depends on:
  Show dependency treegraph
Reported: 2007-10-11 09:54 UTC by Lukas Hasik
Modified: 2007-10-12 14:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT

full thread dump (20.65 KB, text/plain)
2007-10-11 09:54 UTC, Lukas Hasik
stacktrace (13.24 KB, text/plain)
2007-10-11 16:45 UTC, Anton Chechel
stacktrace (14.12 KB, text/plain)
2007-10-12 13:15 UTC, Anton Chechel
stack trace palette (22.17 KB, text/plain)
2007-10-12 13:48 UTC, Karol Harezlak

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2007-10-11 09:54:17 UTC

-deadlock happened when I have opened Visual Designer document and it needs repaint

"AWT-EventQueue-1" prio=6 tid=0x0395c800 nid=0x124c in Object.wait() [0x06daf000..0x06dafc94]
   java.lang.Thread.State: WAITING (on object monitor)
        at java.lang.Object.wait(Native Method)
        at java.lang.Object.wait(Object.java:485)
        at org.openide.util.Task.waitFinished(Task.java:130)
        - locked <0x17f27138> (a org.openide.util.RequestProcessor$Task)
        at org.openide.util.RequestProcessor$Task.waitFinished(RequestProcessor.java:745)
        at org.openide.loaders.FolderChildren.getNodes(FolderChildren.java:192)
        at org.openide.nodes.FilterNode$Children.getNodes(FilterNode.java:1470)
        at org.netbeans.modules.palette.DefaultModel.getCategories(DefaultModel.java:151)
        - locked <0x17ef36c0> (a org.netbeans.modules.palette.DefaultModel)
        at org.netbeans.modules.palette.ui.PalettePanel$1.run(PalettePanel.java:237)
        - locked <0x18133748> (a java.lang.Object)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

-I cannot reproduce. I hope that the full thread dump helps to fix it
Comment 1 Lukas Hasik 2007-10-11 09:54:54 UTC
Created attachment 50669 [details]
full thread dump
Comment 2 Anton Chechel 2007-10-11 16:35:17 UTC
Reassigning to Stanislav.
Comment 3 Anton Chechel 2007-10-11 16:45:42 UTC
Created attachment 50704 [details]
Comment 4 Stanislav Aubrecht 2007-10-11 16:47:36 UTC

/cvs/core/palette/src/org/netbeans/modules/palette/DefaultModel.java,v  <--  DefaultModel.java
new revision: 1.20; previous revision: 1.19
Comment 5 Anton Chechel 2007-10-12 13:14:13 UTC
I just updated core module and its still happens.
Now it is completely reproducible:
- Open Mobility Project
- Open or create new Visual MIDlet
- Delete some category in the palette, for example Items
- Manually Refresh Palette from context menu.

See also stacktrace attached.
Comment 6 Anton Chechel 2007-10-12 13:15:13 UTC
Created attachment 50807 [details]
Comment 7 Stanislav Aubrecht 2007-10-12 13:21:25 UTC
the new stack trace points to an old source file, the bug has been fixed already. please update your source file properly
Comment 8 Karol Harezlak 2007-10-12 13:48:11 UTC
Created attachment 50816 [details]
stack trace palette
Comment 9 Karol Harezlak 2007-10-12 13:50:45 UTC
Last stack trace attached to this issue has been taken with current Palette module sources, unfortunately deadlock still
Comment 10 Stanislav Aubrecht 2007-10-12 14:16:55 UTC
but the line numbers are wrong again, for example
org.netbeans.modules.palette.DefaultModel.childrenAdded(DefaultModel.java:146) points to a closing bracket.

did you checkout/update core/palette from trunk?
Comment 11 Karol Harezlak 2007-10-12 14:31:15 UTC
Yes, I deleted core sources, check out core sources again,even manually deleted core jar from module
../nbbuild/netbeans..in this case i'm gonna check out and compile whole netbeans sources
Comment 12 Karol Harezlak 2007-10-12 14:39:37 UTC
I think I found a problem palette is not comiled inside of core build.xml, yes you right I just tried and dead lock is
not appears any more. Sorry for this mess
Comment 13 Karol Harezlak 2007-10-12 14:43:05 UTC
Yes it definitely works now, whole mess was caused by the old binaries. Thanks again. 

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo