Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 118074 - [unpack200] installer fails with jdk 1.6.0_03
[unpack200] installer fails with jdk 1.6.0_03
Status: RESOLVED DUPLICATE of bug 117334
Product: installer
Classification: Unclassified
Component: Code
6.x
All Windows XP
: P1 (vote)
: TBD
Assigned To: issues@installer
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 09:06 UTC by frankgraf
Modified: 2007-10-09 08:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
log files (205.92 KB, application/octet-stream)
2007-10-08 09:28 UTC, frankgraf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description frankgraf 2007-10-08 09:06:09 UTC
Could not install the netbeans beta 1 using the JDK 1.6.0_03.
It always reported error that unpacking (unpack200) of some files (for the IDE failed).

After uninstalling JDK 1.6.0_03 installation with JDK 1.6.0_02) worked
Comment 1 dlipin 2007-10-08 09:07:45 UTC
frankgraf,

please attach the installation log, it is available at %USERPROFILE%/.nbi/log
Comment 2 frankgraf 2007-10-08 09:28:42 UTC
Created attachment 50366 [details]
log files
Comment 3 frankgraf 2007-10-08 09:32:15 UTC
That seems to be the problem

[2007-10-05 21:39:26.786]: executing command: C:\Program Files\Java\jre1.6.0_03\bin\unpack200.exe C:\Program
Files\NetBeans 6.0 Beta 1\java1\modules\org-netbeans-libs-javacimpl.jar.pack.gz C:\Program Files\NetBeans 6.0 Beta
1\java1\modules\org-netbeans-libs-javacimpl.jar, in directory: .
[2007-10-05 21:39:26.833]:     [return]: -1073741801
[2007-10-05 21:39:26.833]: ... command execution finished
[2007-10-05 21:39:26.833]: org.netbeans.installer.utils.exceptions.InstallationException: Cannot extract installation data
[2007-10-05 21:39:26.833]: 	at org.netbeans.installer.product.components.Product.install(Product.java:243)
[2007-10-05 21:39:26.833]: 	at
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:128)
[2007-10-05 21:39:26.833]: 	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:104)
[2007-10-05 21:39:26.833]: Caused by: java.io.IOException: Unpack200 finished with error
[2007-10-05 21:39:26.833]: Error code: -1,073,741,801
[2007-10-05 21:39:26.833]: Stdout: 
[2007-10-05 21:39:26.833]: Stderr: 
[2007-10-05 21:39:26.833]: 	at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1009)
[2007-10-05 21:39:26.833]: 	at org.netbeans.installer.utils.FileUtils.extractByList(FileUtils.java:1528)
[2007-10-05 21:39:26.833]: 	at org.netbeans.installer.utils.FileUtils.extractAll(FileUtils.java:1448)
[2007-10-05 21:39:26.833]: 	at org.netbeans.installer.utils.FileUtils.unjar(FileUtils.java:911)
[2007-10-05 21:39:26.833]: 	at org.netbeans.installer.product.components.Product.install(Product.java:232)
[2007-10-05 21:39:26.833]: 	... 2 more
Comment 4 dlipin 2007-10-08 09:54:28 UTC
frankgraf,

we have already similar Issue 117334.

The problem is in the monitoring tool called "Logitech Process Monitor" (lvprcsrv.exe).
Please make sure that you are not running this or any other processes monitoring tool.

Could you please add your running processes list to that issue (117334)?
You can get the list by executing the following command:
C:\WINDOWS\system32\tasklist.exe /V /FO TABLE > processes.txt

Thanks,
Dmitry

*** This issue has been marked as a duplicate of 117334 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo