Bug 117877 - [60cat] No managed beans available in JSP Completion
[60cat] No managed beans available in JSP Completion
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: _ potingwu
issues@javaee
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 08:08 UTC by jlaskowski
Modified: 2008-05-16 23:33 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jlaskowski 2007-10-05 08:08:56 UTC
[ BUILD # : 200710040000 ]
[ JDK VERSION : 1.6.0_02 ]

I couldn't track down how to reproduce the issue for a long time
until I've finally figured it out. It's reproducible, but the step
order is important. It happened right after I'd upgraded NB to the
latest nightly build.

0/ Define a Java EE server
1/ Create a JSF webapp
2/ Create a managed bean - employee - with some properties
3/ Close NB
4/ Remove NB home repository, i.e. ~/.netbeans
5/ Open NB and the webapp project (there should be a warning message
that the appserver's not defined - we'll get back to it soon)
6/ I'm not sure whether it's required or not, but do it just to
reproduce the issue - select Run menu from the project context menu.
You should see an error that no appserver's defined.
7/ Define an jee appserver and select it for the project
8/ run Clean and Build in the project (I think that's one of the most
important step to reproduce the issue as likely some NB internal
helper files are gone afterwards from dist/build directories or such)
9/ Open welcomeJSF.jsp file and type in <h:outputText value="#{">.
Press Ctrl+Space to open up JSP completion. No managed beans are
available.

(!) After a while the managed beans from the project are available
already.
Comment 1 Andrei Badea 2007-10-16 11:10:25 UTC
Sorry, I can't reproduce this. Can you reproduce in the latest daily build? By the way, in step 9, is there any
difference if you wait until the Java classpath scan finishes?
Comment 2 Andrei Badea 2007-10-16 13:29:55 UTC
Actually, perhaps I found a way to reproduce this while working on another issue.

1. In a JSP file type "<h:outputLink ".
2. Invoke code completion, type "va", press Tab. The IDE completes to "value".
3. Type '="#{' (without the apostrophes. The code completion comes up with the managed bean missing.
Comment 3 Jiri Prox 2008-04-11 01:19:45 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 4 _ potingwu 2008-05-15 21:06:33 UTC
The code completion for the managed beans is now more robust and I no longer see this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo