Bug 117673 - "java.lang.NumberFormatException: multiple points" with 10/3 nightly
"java.lang.NumberFormatException: multiple points" with 10/3 nightly
Status: RESOLVED DUPLICATE of bug 117536
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All Windows Vista
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 17:22 UTC by arungupta
Modified: 2007-10-05 16:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arungupta 2007-10-03 17:22:38 UTC
I downloaded and installed 10/3 nightly build. After I start the IDE it looks for Updates and throws the following
exception:

java.lang.NumberFormatException: multiple points
	at sun.misc.FloatingDecimal.readJavaFormatString(FloatingDecimal.java:1084)
	at java.lang.Double.parseDouble(Double.java:482)
	at java.text.DigitList.getDouble(DigitList.java:141)
	at java.text.DecimalFormat.parse(DecimalFormat.java:1276)
	at java.text.SimpleDateFormat.subParse(SimpleDateFormat.java:1375)
	at java.text.SimpleDateFormat.parse(SimpleDateFormat.java:1124)
	at java.text.DateFormat.parse(DateFormat.java:333)
	at org.netbeans.modules.autoupdate.updateprovider.ModuleItem.<init>(ModuleItem.java:103)
	at org.netbeans.spi.autoupdate.UpdateItem.createModule(UpdateItem.java:110)
	at org.netbeans.modules.autoupdate.updateprovider.SimpleItem$Module.toUpdateItem(SimpleItem.java:287)
	at org.netbeans.modules.autoupdate.updateprovider.SimpleItem$Module.toUpdateItem(SimpleItem.java:209)
	at org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getUpdateItems(AutoupdateCatalogParser.java:112)
	at
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogProvider.getUpdateItems(AutoupdateCatalogProvider.java:114)
	at org.netbeans.modules.autoupdate.services.UpdateUnitFactory.appendUpdateItems(UpdateUnitFactory.java:190)
	at org.netbeans.modules.autoupdate.services.UpdateUnitFactory.getUpdateUnits(UpdateUnitFactory.java:140)
	at org.netbeans.modules.autoupdate.services.UpdateManagerImpl$Cache.<init>(UpdateManagerImpl.java:186)
	at org.netbeans.modules.autoupdate.services.UpdateManagerImpl.getCache(UpdateManagerImpl.java:162)
	at org.netbeans.modules.autoupdate.services.UpdateManagerImpl.getUpdateUnits(UpdateManagerImpl.java:91)
	at org.netbeans.api.autoupdate.UpdateManager.getUpdateUnits(UpdateManager.java:100)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler$3.run(AutoupdateCheckScheduler.java:132)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)


I can click on Close button and continue work but this needs to be fixed.
Comment 1 rmatous 2007-10-05 16:37:39 UTC

*** This issue has been marked as a duplicate of 117536 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo