Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 117653 - Incoming/Outgoing view.
Incoming/Outgoing view.
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 126220 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 15:39 UTC by Peter Pis
Modified: 2008-02-05 22:09 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
65123_75a6068f4198 - Show Out support (23.16 KB, text/plain)
2008-01-31 07:57 UTC, John Rice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2007-10-03 15:39:07 UTC
Product Version: NetBeans IDE Dev (Build 200710030000) Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b05 System:
Windows XP version 5.1 running on x86; Cp1252; en_GB (nb) Userdir: D:\ide\60daily\user

It would be great if users have an opportunity to list changes from the original repository. Something like "Status"
view that could show incoming/outgoing changes.
Comment 1 Peter Pis 2008-01-30 07:30:38 UTC
*** Issue 126220 has been marked as a duplicate of this issue. ***
Comment 2 John Rice 2008-01-30 09:23:24 UTC
Will reuse the Show History code to implement this functionality, will just need a switch to customize how the
underlying history data is being generated in each case, History - hg log, Out - hg out, Incoming hg incoming and
hide/show various elements of the Search History dialog and label appropriately.
Comment 3 John Rice 2008-01-31 07:56:57 UTC
changeset:   65123:75a6068f4198
tag:         tip
user:        jrice@netbeans.org
date:        Thu Jan 31 00:51:11 2008 +0000
summary:     #117653: Added support for Show Out - will show all outgoing changesets in Show History style, allowing
diff and revert
Comment 4 John Rice 2008-01-31 07:57:59 UTC
Created attachment 55814 [details]
65123_75a6068f4198 - Show Out support
Comment 5 John Rice 2008-01-31 08:34:45 UTC
Note in Head: rev 65300 cset 75a6068f4198
Comment 6 John Rice 2008-02-05 22:09:21 UTC
Mercurial Push
--------------
INFO Changesets to push:
changeset:   65973:cbf7ffac44e1
user:        jrice@netbeans.org
date:        Tue Feb 05 21:59:47 2008 +0000
files:       mercurial/src/org/netbeans/modules/mercurial/Bundle.properties
mercurial/src/org/netbeans/modules/mercurial/MercurialAnnotator.java
mercurial/src/org/netbeans/modules/mercurial/ui/log/Bundle.properties
mercurial/src/org/netbeans/modules/mercurial/ui/log/IncomingAction.java
mercurial/src/org/netbeans/modules/mercurial/ui/log/SearchExecutor.java
mercurial/src/org/netbeans/modules/mercurial/ui/log/SearchHistoryAction.java
mercurial/src/org/netbeans/modules/mercurial/ui/log/SearchHistoryPanel.java
mercurial/src/org/netbeans/modules/mercurial/ui/log/SearchHistoryTopComponent.java
mercurial/src/org/netbeans/modules/mercurial/ui/log/SummaryView.java
mercurial/src/org/netbeans/modules/mercurial/util/HgCommand.java
description:
#117653: Adding Incoming support - can only show changeset summary, remote diff is not supported.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo