Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 117632 - Problems committing deletion.
Problems committing deletion.
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 118485 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 14:26 UTC by Peter Pis
Modified: 2008-01-03 09:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (63.10 KB, text/plain)
2007-10-04 13:25 UTC, Peter Pis
Details
proposed patch (1.15 KB, patch)
2007-10-05 08:52 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2007-10-03 14:26:04 UTC
Product Version: NetBeans IDE Dev (Build 200710030000) Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b05 System:
Windows XP version 5.1 running on x86; Cp1252; en_GB (nb) Userdir: D:\ide\60daily\user

Steps:
Steps:
1. Invoke "Versioning | Mercurial | Clone Other...".
2. Setup valid "Repository URL" where the nbproject. Push "Next" button.
3. Specify valid "Target Directory". Push "Finish" button.
4. Open cloned project and invoke "Status" action on project root node.
5. Create new JFrame.
6. Commit JFrame.
7. Delete JFrame.
8. Commit deletion from within "Mercurial - Status" view.

Files (JFrame.java and JFrame.form) are still visible in "Status" view. If the Frame is selected in a view it can be
committed as expected. Haven't encountered it for single files such as java classes and so on.
Comment 1 Peter Pis 2007-10-03 14:31:59 UTC
Steps:
1. Invoke "Versioning | Mercurial | Clone Other...".
2. Setup valid "Repository URL" where the nbproject. Push "Next" button.
3. Specify valid "Target Directory". Push "Finish" button.
4. Open cloned project and invoke "Status" action on project root node.
5. Delete some versioned file.
6. Select project root (or from Status view) and invoke "Commit" action. 
7. Commit dialog list deleted file, push "Commit" button.

File is still in "Status" view and blue badge indicates the modification for parent folder. So it's been experienced for
single files too.
Comment 2 Padraig Obriain 2007-10-04 12:50:43 UTC
Peter,

Can you repeat this with -J-Dorg.netbeans.modules.mercurial.level=100 added to netbeans_default_options in
etc/netbeans.conf and attach the message log.

This sounds similar to a problem the openjdk people are having and sounds like it may be caused by a bug in mercurial.
Comment 3 Peter Pis 2007-10-04 13:25:37 UTC
Created attachment 50174 [details]
messages.log
Comment 4 Padraig Obriain 2007-10-05 08:22:08 UTC
This is not related to the problem the openjdk people are having.

After deleting the file if I press Commit All button in the Status Window I see the problem. If I right click on the
deleted file and press Commit then the status of the deleted file is updated correctly.

Comment 5 Padraig Obriain 2007-10-05 08:52:18 UTC
Created attachment 50251 [details]
proposed patch
Comment 6 Padraig Obriain 2007-10-05 08:58:05 UTC
This was a regression caused by improving the performance of FileStatusCache.refreshCached(context).

Patch committed to CVS HEAD.
Comment 7 Padraig Obriain 2007-10-11 10:46:22 UTC
*** Issue 118485 has been marked as a duplicate of this issue. ***
Comment 8 Peter Pis 2007-10-19 09:46:35 UTC
Verified.

Product Version: NetBeans IDE 6.0 Beta 2 (Build 200710181000)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Userdir: D:\ide\60beta\user
Mercurial plugin        = 1.4.0.42.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo