Bug 117458 - Add Favorite with NB project blocks IDE UI for a minute
Add Favorite with NB project blocks IDE UI for a minute
Status: RESOLVED WONTFIX
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 14:24 UTC by ehucka
Modified: 2007-10-24 22:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
threaddump (19.56 KB, text/plain)
2007-10-02 14:25 UTC, ehucka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ehucka 2007-10-02 14:24:42 UTC
Product Version: NetBeans IDE Dev (Build 20071002030624) Java: 1.6.0_02; Java HotSpot(TM) Server VM 1.6.0_02-b05 System:
Linux version 2.6.20-16-generic running on i386; UTF-8; en_US (nb)

I have added an entry to Favorites view containing an nb module. Ide froze for a minute without any UI indication it is
doing something - no progress, no wait dialog.
Comment 1 ehucka 2007-10-02 14:25:33 UTC
Created attachment 49987 [details]
threaddump
Comment 2 Jesse Glick 2007-10-02 14:54:24 UTC
The tasklist node annotator is blocking EQ asking for project metadata. I don't see any simple way to make this
asynchronous. apisupport could probably make the query return more quickly with some rewrites.

Do not consider performance issues on nb.org projects to be P2 - they only affect a handful of people. Those people can
wait. Not worth wasting development time on this. A scan is done when you first need information about a given nb.org
checkout; this info is cached for the rest of the IDE session.
Comment 3 Oleg Khokhlov 2007-10-17 17:06:12 UTC
this one and http://www.netbeans.org/issues/show_bug.cgi?id=119004 look similar to me.
Comment 4 Jesse Glick 2007-10-17 18:49:36 UTC
I think they are different - this freeze is caused by the task list, not Favorites window as such - but since issue
#119004 lacks any thread dumps, it is hard to say.

(BTW: you do need to paste in an entire hyperlink to another issue, just type in issue #nnnnnn as above.)
Comment 5 Jesse Glick 2007-10-24 22:55:09 UTC
After issue #114155, should be much faster in case you have a built source tree (technically, an up-to-date
nbbuild/nbproject/private/scan-cache-full.ser).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo