Bug 117334 - [unpack200] Strange errorcode (-1073741801) is returned on unpack200 command
[unpack200] Strange errorcode (-1073741801) is returned on unpack200 command
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: dlipin
issues@installer
: RELNOTE
: 118074 187749 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 15:47 UTC by egiraudy
Modified: 2010-06-18 17:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
full installation log (222.16 KB, text/plain)
2007-10-01 15:49 UTC, egiraudy
Details
full log file (JRE 1.5.0_12) (387.53 KB, application/octet-stream)
2007-10-01 16:44 UTC, egiraudy
Details
org-netbeans-modules-jsp-lexer.jar (28.25 KB, application/octet-stream)
2007-10-01 16:57 UTC, egiraudy
Details
process list (17.44 KB, text/plain)
2007-10-02 09:38 UTC, egiraudy
Details
environment (1.22 KB, application/octet-stream)
2007-10-05 13:57 UTC, egiraudy
Details
test program (1.61 MB, application/octet-stream)
2007-10-05 15:31 UTC, dlipin
Details
process list from my(frankgraf) pc (14.79 KB, text/plain)
2007-10-08 12:25 UTC, frankgraf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description egiraudy 2007-10-01 15:47:41 UTC
netbeans-trunk-nightly-200710010000-javaee-windows.exe installation failed (netbeans-trunk-nightly-200709290000-javaee-
windows.exewas successful) with the following error:

[2007-10-01 16:28:39.501]: extracting D:\dev\nb\java1\modules\org-netbeans-modules-java-helpset.jar.pack.gz
[2007-10-01 16:28:39.517]: executing command: C:\Program Files\Java\jre1.6.0_02\bin\unpack200.exe 
D:\dev\nb\java1\modules\org-netbeans-modules-java-helpset.jar.pack.gz D:\dev\nb\java1\modules\org-netbeans-modules-java-
helpset.jar, in directory: .
[2007-10-01 16:28:39.563]:     [return]: -1073741801
[2007-10-01 16:28:39.563]: ... command execution finished
[2007-10-01 16:28:39.563]: org.netbeans.installer.utils.exceptions.InstallationException: Cannot extract installation 
data for Java SE
[2007-10-01 16:28:39.563]: 	at org.netbeans.installer.product.components.Product.install(Product.java:269)
[2007-10-01 16:28:39.563]: 	at 
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:128)
[2007-10-01 16:28:39.563]: 	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:104)
[2007-10-01 16:28:39.563]: Caused by: java.io.IOException: Unpack200 finished with error
[2007-10-01 16:28:39.563]: Error code: -1 073 741 801
[2007-10-01 16:28:39.563]: Stdout: 
[2007-10-01 16:28:39.563]: Stderr: 
[2007-10-01 16:28:39.563]: 	at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1009)
[2007-10-01 16:28:39.563]: 	at org.netbeans.installer.utils.FileUtils.extractByList(FileUtils.java:1528)
[2007-10-01 16:28:39.563]: 	at org.netbeans.installer.utils.FileUtils.extractAll(FileUtils.java:1448)
[2007-10-01 16:28:39.563]: 	at org.netbeans.installer.utils.FileUtils.unjar(FileUtils.java:911)
[2007-10-01 16:28:39.563]: 	at org.netbeans.installer.product.components.Product.install(Product.java:259)
[2007-10-01 16:28:39.563]: 	... 2 more

Installation options: No glassfish, tomcat 6.0.14 already installed.
Comment 1 egiraudy 2007-10-01 15:49:18 UTC
Created attachment 49899 [details]
full installation log
Comment 2 dlipin 2007-10-01 16:02:34 UTC
Well..
it is the second time I see the error with unpacker (unpack200) from JDK1.6.0_02 distribution (see also Issue 115900).
This time it returns ugly error code (-1073741801).


egiraudy,

could you please install JDK 1.5.0_12 and try it for installation? 
(you can set the JVM to be used by installer by --javahome command line argument)

Thanks,
Dmitry
Comment 3 egiraudy 2007-10-01 16:42:56 UTC
Same story with JRE 1.5.0_12: same error, but not on the same file.

Q: why can't the installer run from a JDK? (why does it needs a JRE?)

[2007-10-01 17:38:04.834]: executing command: c:\jdk15.0\jre\bin\unpack200.exe D:\dev\nb\visualweb1\modules\org-
netbeans-modules-visualweb-webui-jsf-defaulttheme.jar.pack.gz D:\dev\nb\visualweb1\modules\org-netbeans-modules-
visualweb-webui-jsf-defaulttheme.jar, in directory: .
[2007-10-01 17:38:04.880]:     [return]: -1073741801
[2007-10-01 17:38:04.880]: ... command execution finished
[2007-10-01 17:38:04.880]: org.netbeans.installer.utils.exceptions.InstallationException: Cannot extract installation 
data for Web & Java EE
[2007-10-01 17:38:04.880]: 	at org.netbeans.installer.product.components.Product.install(Product.java:269)
[2007-10-01 17:38:04.880]: 	at 
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:128)
[2007-10-01 17:38:04.880]: 	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:104)
[2007-10-01 17:38:04.880]: Caused by: java.io.IOException: Unpack200 finished with error
[2007-10-01 17:38:04.880]: Error code: -1 073 741 801
[2007-10-01 17:38:04.880]: Stdout: 
[2007-10-01 17:38:04.880]: Stderr: 
[2007-10-01 17:38:04.880]: 	at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1009)
[2007-10-01 17:38:04.880]: 	at org.netbeans.installer.utils.FileUtils.extractByList(FileUtils.java:1528)
[2007-10-01 17:38:04.880]: 	at org.netbeans.installer.utils.FileUtils.extractAll(FileUtils.java:1448)
[2007-10-01 17:38:04.880]: 	at org.netbeans.installer.utils.FileUtils.unjar(FileUtils.java:911)
[2007-10-01 17:38:04.880]: 	at org.netbeans.installer.product.components.Product.install(Product.java:259)
[2007-10-01 17:38:04.880]: 	... 2 more
Comment 4 egiraudy 2007-10-01 16:44:15 UTC
Created attachment 49905 [details]
full log file (JRE 1.5.0_12)
Comment 5 dlipin 2007-10-01 16:49:46 UTC
egiraudy,

actually installer can run on JRE, JDK is required for NetBeans itself.

Could you please attach that file (D:\dev\nb\visualweb1\modules\org-
netbeans-modules-visualweb-webui-jsf-defaulttheme.jar.pack.gz) to this issue?

Do you have any antivirus software running on your system? 
If yes, could you please turn it temporary off and give another try?

Could you please also check the md5 of the installer? 
for netbeans-trunk-nightly-200710010000-javaee-windows.exe it should be equal to E33BC7B3663FA024A6B6BCC0A2C01D73.

Do you experience this issue with NetBeans 6.0 Beta 1 ?

Thanks,
Dmitry
Comment 6 dlipin 2007-10-01 16:51:28 UTC
and, btw, do you have the latest OS updates installed? 
Or the SP2 is the latest update from Microsoft that you have installed?
Comment 7 egiraudy 2007-10-01 16:56:30 UTC
With my antivirus disabled (bit defender) I still have the error, but again on a different file.

[2007-10-01 17:54:21.792]: executing command: c:\jdk15.0\jre\bin\unpack200.exe D:\dev\nb\enterprise4\modules\org-
netbeans-modules-jsp-lexer.jar.pack.gz D:\dev\nb\enterprise4\modules\org-netbeans-modules-jsp-lexer.jar, in directory: .
[2007-10-01 17:54:21.854]:     [return]: -1073741801
[2007-10-01 17:54:21.854]: ... command execution finished
[2007-10-01 17:54:21.854]: org.netbeans.installer.utils.exceptions.InstallationException: Cannot extract installation 
data for Web & Java EE
[2007-10-01 17:54:21.854]: 	at org.netbeans.installer.product.components.Product.install(Product.java:269)
[2007-10-01 17:54:21.854]: 	at 
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:128)
[2007-10-01 17:54:21.854]: 	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:104)
[2007-10-01 17:54:21.854]: Caused by: java.io.IOException: Unpack200 finished with error
[2007-10-01 17:54:21.854]: Error code: -1 073 741 801
[2007-10-01 17:54:21.854]: Stdout: 
[2007-10-01 17:54:21.854]: Stderr: 
[2007-10-01 17:54:21.854]: 	at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1009)
[2007-10-01 17:54:21.854]: 	at org.netbeans.installer.utils.FileUtils.extractByList(FileUtils.java:1528)
[2007-10-01 17:54:21.854]: 	at org.netbeans.installer.utils.FileUtils.extractAll(FileUtils.java:1448)
[2007-10-01 17:54:21.854]: 	at org.netbeans.installer.utils.FileUtils.unjar(FileUtils.java:911)
[2007-10-01 17:54:21.854]: 	at org.netbeans.installer.product.components.Product.install(Product.java:259)
[2007-10-01 17:54:21.854]: 	... 2 more
Comment 8 egiraudy 2007-10-01 16:57:20 UTC
Created attachment 49908 [details]
org-netbeans-modules-jsp-lexer.jar
Comment 9 egiraudy 2007-10-01 17:22:01 UTC
About my system, yes, i do have the latest updates for SP2
Comment 10 dlipin 2007-10-02 08:10:30 UTC
a couple of additional questions:
how much memory do you have? 
what processor(s) do you have?

Thanks,
Dmitry
Comment 11 egiraudy 2007-10-02 08:32:03 UTC
CPU: Core 2 Duo 2Ghz
Mem: 2 Gb

FYI, as mentionned in the issue description, I'm able to install back netbeans-trunk-nightly-200709290000-javaee-
windows.exe after each unsuccessful installation of more recent nighltlies(this morning, netbeans-trunk-nightly-
200710011200-javaee-windows.exe failed also).
Comment 12 dlipin 2007-10-02 09:20:52 UTC
Unfortunately I still can`t reproduce the issue so additional investigation is reguired.

could you please make a list of the processes normally running ?

you can make a list with a help of tasklist.exe programm:
C:\WINDOWS\system32\tasklist.exe /V /FO TABLE > log.txt
Comment 13 egiraudy 2007-10-02 09:38:21 UTC
Created attachment 49962 [details]
process list
Comment 14 egiraudy 2007-10-03 08:31:58 UTC
This morning, I've been able to install the latest nightly (netbeans-trunk-nightly-200710020000-javaee-windows.exe), 
which BTW seems to have a slightly modified installer.

You may close this issue unless you want to track down the issue.

Thanks,
Etienne
Comment 15 dlipin 2007-10-03 08:46:21 UTC
Well...

I have not done anything in the pack/unpack area and "slightly modified installer", I guess, means the UI.

So the issue seems to be sporadic. BTW, did you restarted the OS by chance?
I assume that this strange error code can be the result of the memory leaks in unpack200.
Unfortunately I don`t have the strong evidence for that just the 2 issues:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6545954
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6531345

I will lower the priority so feel free to add comments later if you run into similar problems.
Comment 16 mslama 2007-10-03 12:52:17 UTC
I do not think this can be anyhow connected with memory leak....
Comment 17 dlipin 2007-10-03 13:06:35 UTC
Marek,

any other ideas? error in Java`s ProcessBuilder?
Comment 18 egiraudy 2007-10-04 09:07:17 UTC
This morning I had the issue again with netbeans-trunk-nightly-200710031200-javaee-windows.exe:

[2007-10-04 09:49:53.411]: extracting D:\dev\nb\java1\modules\ext\AbsoluteLayout.jar.pack.gz
[2007-10-04 09:49:53.411]: executing command: C:\Program Files\Java\jre1.6.0_02\bin\unpack200.exe 
D:\dev\nb\java1\modules\ext\AbsoluteLayout.jar.pack.gz D:\dev\nb\java1\modules\ext\AbsoluteLayout.jar, in directory: .
[2007-10-04 09:49:53.474]:     [return]: -1073741801
[2007-10-04 09:49:53.474]: ... command execution finished
[2007-10-04 09:49:53.474]: org.netbeans.installer.utils.exceptions.InstallationException: Cannot extract installation 
data for Java SE
[2007-10-04 09:49:53.474]: 	at org.netbeans.installer.product.components.Product.install(Product.java:269)
[2007-10-04 09:49:53.474]: 	at 
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:128)
[2007-10-04 09:49:53.474]: 	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:104)
[2007-10-04 09:49:53.474]: Caused by: java.io.IOException: Unpack200 finished with error
[2007-10-04 09:49:53.474]: Error code: -1 073 741 801
[2007-10-04 09:49:53.474]: Stdout: 
[2007-10-04 09:49:53.474]: Stderr: 
[2007-10-04 09:49:53.474]: 	at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1065)
[2007-10-04 09:49:53.474]: 	at org.netbeans.installer.utils.FileUtils.extractByList(FileUtils.java:1584)
[2007-10-04 09:49:53.474]: 	at org.netbeans.installer.utils.FileUtils.extractAll(FileUtils.java:1504)
[2007-10-04 09:49:53.474]: 	at org.netbeans.installer.utils.FileUtils.unjar(FileUtils.java:911)
[2007-10-04 09:49:53.474]: 	at org.netbeans.installer.product.components.Product.install(Product.java:259)


I did check in the install directory, and D:\dev\nb\java1\modules\ext\AbsoluteLayout.jar was unpacked and correct.

For testing, I uninstalled and reinstalled the same build and this it worked...

Environment related issue?
Comment 19 dlipin 2007-10-05 13:08:22 UTC
possibly, yes, it`s environment related issue..
possibly - we handle java`s ProcessBuilder and Process in a not exact way...

could you please attach your environment? you can get it by 
Start->Run->cmd 
and then type "set >> env.txt" in cmd window.

You can certainly remove any secret info (e.g. passwords) from env.txt.

Thanks,
Dmitry
Comment 20 egiraudy 2007-10-05 13:57:05 UTC
Created attachment 50264 [details]
environment
Comment 21 dlipin 2007-10-05 15:30:59 UTC
egiraudy,
thanks for the environment.. I don`t see any strange in it.

I attach the 'test' program that can help to catch the issue.
Could you please download the attached zip file, extract it to the empty directory, goto to this directory and run
C:\Program Files\Java\jre1.6.0_02\bin\java.exe -jar unpack.jar 100

This test jar will try to unpack 3 packed files (that goes in the zip archive) for 100 times.

If it fail (an error will be shown in the output) - please let me know...
If not please run the same command with the last argument "1000" (instead of 100) and please let me know the results.

Thanks a lot for you incredible help,
Dmitry
Comment 22 dlipin 2007-10-05 15:31:38 UTC
Created attachment 50271 [details]
test program
Comment 23 egiraudy 2007-10-05 16:14:06 UTC
it did work with 100 and 1000, so i tried with 5000 and here is the result:

c:\temp\test>"C:\Program Files\Java\jre1.6.0_02\bin\java.exe" -jar unpack.jar 5000
Completed : 0%
Completed : 1%
Completed : 2%
Completed : 3%
Completed : 4%
Completed : 5%
Completed : 6%
Completed : 7%
Cannot unpack file : c:\temp\test\.\org-netbeans-modules-visualweb-webui-jsf-defaulttheme.jar.pack.gz
java.io.IOException: Unpack200 finished with error
Error code: -1á073á741á801
Stdout:
Stderr:
        at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1081)
        at org.netbeans.installer.Installer.main(Installer.java:117)

Before you ask, i do have loads of rfee space on my c: drive (>30Go)

Hope that helps...
Comment 24 dlipin 2007-10-05 16:50:07 UTC
egiraudy,

that helps somehow.. this test shows that the issue is either in java`s unpack200.exe or in our 
SystemUtils.executeCommand() method...


To check whether it is the unpack.exe bug, could you please save the following as the .bat file, put it in the 
directory where you have extracted the previous zip file and run in cmd?
If there is an error in unpack200, then this cycle will end in some time..

@echo OFF
:Repeat
"C:\Program Files\Java\jre1.6.0_02\bin\unpack200.exe" org-netbeans-modules-visualweb-webui-jsf-defaulttheme.jar.pack.gz 
org-netbeans-modules-visualweb-webui-jsf-defaulttheme.jar
IF %ERRORLEVEL%==0 GOTO Repeat
echo Failed to unpack with error level : %ERRORLEVEL%
Comment 25 egiraudy 2007-10-05 17:07:58 UTC
the result...

Failed to unpack with error level : -1073741801
Comment 26 dlipin 2007-10-06 20:19:51 UTC
great... then it the definitely not the installer issue
something related to unpack200/environment/running programms/memory/harddisk/OS/whatever..
Comment 27 dlipin 2007-10-06 21:21:38 UTC
egiraudy,

If you are interested (as I am) to find out the exact reason of the issue, at the first step we can identify if it is 
the influence of one of the running programms. 
To do that you can stop most of the services running and exit all the programs running including those that are running 
in background and those that are in the system tray. The special attention should be made for monitoring/indexing tools 
(e.g. GoogleDesktop/Acer eRecovery Management/etc). This services/process shutdown can be made in several steps to 
identify the exact program that has such an effect. In other words, it would be great to do the following : 
1) Run that .bat file and check if the issue is reproducible
2) Exit N programms or stop N services (e.g. N=3)
3) Run .bat file again. If the issue is no more reproducible - than it is one of those N programs/services
4) If reproducible - go to point 2 and do the same steps again...

BTW, how much time does the .bat file run (approximately) before failure?

egiraudy,
thanks for your help and cooperation.
I hope that finally we will find the reason.
Comment 28 dlipin 2007-10-07 10:47:05 UTC
egiraudy,

to check for sure whether it is he unpack200 issue, you can run Windows in safe mode and run that but file.

If it fails even in safe mode then it is 100% unpack200 issue and I will find the appropriate bug against unpack200 it 
in Sun`s Bugtrack.
If not than it is the issue of environment..
Comment 29 egiraudy 2007-10-07 13:36:36 UTC
OK, I think I've found the source of the issue.
That's 'Logitech LVPrcSrv service' (lvprcsrv.exe, v9.4.4.1069). I've De-activated the service (which obviously I've no 
usage for) that seems to cause the issue (googling around shows that is often a source of issue) and the test do not 
fail anymore.
Comment 30 dlipin 2007-10-08 09:54:27 UTC
*** Issue 118074 has been marked as a duplicate of this issue. ***
Comment 31 dlipin 2007-10-08 09:54:58 UTC
adding frankgraf to the CC list : this user also experience this issue.
Comment 32 frankgraf 2007-10-08 12:25:35 UTC
Created attachment 50369 [details]
process list from my(frankgraf) pc
Comment 33 dlipin 2007-10-08 12:50:37 UTC
frankgraf,

turn off the Logitech QuickCam service (lvprcsrv.exe) and give another try to installation.
Most probably the issue would not reproduce..
Comment 34 frankgraf 2007-10-09 08:48:32 UTC
After disabling the   Logitech QuickCam service (lvprcsrv.exe) I could without any problem install jdk_1.6.0_03 again
and reinstall Netbeans
Comment 35 dlipin 2007-10-09 08:52:40 UTC
Fixed.

Now this errorcode in unpack200 commmand is not treated as the error but the warning is shown in the installation log.

Checking in FileUtils.java;
/cvs/nbi/engine/src/org/netbeans/installer/utils/FileUtils.java,v  <--  FileUtils.java
new revision: 1.79; previous revision: 1.78
done
Comment 36 dlipin 2009-05-16 22:17:11 UTC
*** Issue 165319 has been marked as a duplicate of this issue. ***
Comment 37 dlipin 2010-06-18 17:18:15 UTC
*** Bug 187749 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo