Bug 117280 - ShellScriptResolver should be rewritten declaratively and reordered
ShellScriptResolver should be rewritten declaratively and reordered
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: sh
6.x
All All
: P4 (vote)
: 6.x
Assigned To: Jan Jancura
issues@obsolete
: PERFORMANCE, SIMPLEFIX
: 119099 (view as bug list)
Depends on: 31977
Blocks: 114195
  Show dependency treegraph
 
Reported: 2007-10-01 11:17 UTC by Petr Nejedly
Modified: 2009-02-19 21:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Nejedly 2007-10-01 11:17:35 UTC
ShellScriptResolver, which is a sniffing MIMEResolver (opens some of the files it encounters) should rather be ordered
near the end of MIMEResolvers list (but before CND's executable file resolvers, which matches any file beginning with "#!").
As it is declared through META-INF/services (which is otherwise the best way to go), it gets evaluated among the first,
which is neither in line with its importance, nor with its sniffing nature.

To impose ordering on it, you have to rewrite it into declarative form (using "magic" tag, see e.g.
http://www.netbeans.org/source/browse/*checkout*/cnd/core/src/org/netbeans/modules/cnd/resources/mime-resolver.xml?content-type=text%2Fplain&rev=1.7
), which is good anyway for allowing further speedup in the mime resolution infrastructure.
Comment 1 Petr Nejedly 2007-10-16 19:15:17 UTC
*** Issue 119099 has been marked as a duplicate of this issue. ***
Comment 2 Jesse Glick 2007-10-16 19:55:04 UTC
Needed fix of issue #31977 for this to be rewritten in XML.
Comment 3 Jesse Glick 2007-10-24 15:25:37 UTC
It is a performance defect the way it is.
Comment 4 Jiri Skrivanek 2008-11-18 14:45:12 UTC
Fixed in issue 142760.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo