Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 116945 - java.lang.IllegalArgumentException: getParent() called for DE (2380358)["..." (content) <1003-1008> ''] which is not in the elements list!
java.lang.IllegalArgumentException: getParent() called for DE (2380358)["..."...
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Code
6.x
Sun Linux
: P2 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, release601_fixes_c...
:
: 119563 120691 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 13:52 UTC by Jiri Skrivanek
Modified: 2008-08-28 05:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.37 KB, text/plain)
2007-09-27 13:52 UTC, Jiri Skrivanek
Details
stacktrace (1.37 KB, text/plain)
2007-10-03 14:19 UTC, Tomas Danek
Details
stacktrace (1.39 KB, text/plain)
2007-10-03 23:36 UTC, Jun Qian
Details
stacktrace (1.37 KB, text/plain)
2007-10-17 15:54 UTC, pzajac
Details
stacktrace (1.39 KB, text/plain)
2007-11-21 17:22 UTC, Roman Mostyka
Details
stacktrace (1.37 KB, text/plain)
2007-12-05 14:33 UTC, Tomas Danek
Details
stacktrace (1.37 KB, text/plain)
2007-12-06 16:03 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2007-09-27 13:52:42 UTC
Build: NetBeans IDE Dev (Build 200709270433)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b02
OS: Windows XP, 5.1, x86

User Comments: 
To reproduce:

- create web project with JSF
- open Configuration Files|faces-config.xml
- call JSF|Add Navigation Case popup in editor
- fill some values in the dialog and confirm dialog
- remove line by line added elements from faces-config.xml and you get the exception.
Comment 1 Jiri Skrivanek 2007-09-27 13:52:46 UTC
Created attachment 49680 [details]
stacktrace
Comment 2 Tomas Danek 2007-10-03 14:19:43 UTC
Build: NetBeans IDE Dev (Build 200710030000)
VM: Java HotSpot(TM) Client VM, 1.6.0_01-b06
OS: Linux, 2.6.20-16-generic, i386

User Comments: 
Comment 3 Tomas Danek 2007-10-03 14:19:52 UTC
Created attachment 50093 [details]
stacktrace
Comment 4 Jun Qian 2007-10-03 23:35:57 UTC
Build: NetBeans IDE Dev (Build 070926)
VM: Java HotSpot(TM) Client VM, 1.6.0_02-b06
OS: Windows XP, 5.1, x86

User Comments: 
Comment 5 Jun Qian 2007-10-03 23:36:04 UTC
Created attachment 50148 [details]
stacktrace
Comment 6 pzajac 2007-10-17 15:54:11 UTC
Build: NetBeans IDE Dev (Build 20071017095837)
VM: Java HotSpot(TM) Client VM, 1.6.0_02-b05
OS: Linux, 2.6.20-16-generic, i386

User Comments: 
The exception was thrown after deleting  xml tags in jnlp file. I don't know how to reproduce it.
Comment 7 pzajac 2007-10-17 15:54:22 UTC
Created attachment 51129 [details]
stacktrace
Comment 8 giorgio42 2007-10-18 14:32:59 UTC
THIS ISSUE HAS 5 MORE DUPLICATES
Comment 9 Jun Qian 2007-11-01 22:34:58 UTC
*** Issue 120691 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Skrivanek 2007-11-15 18:40:22 UTC
Raising priority because of too many duplicates.
Comment 11 Samaresh Panda 2007-11-15 19:03:06 UTC
giorgio42,
Can you please list all five duplicates? I just see one issue 120691 reported as duplicate.
Comment 12 Jiri Skrivanek 2007-11-15 20:54:17 UTC
The message by giorgio42 was generated automatically by the exception reporter tool. To see duplicates, go to the URL.
This exception was already reported 34 times!
Comment 13 Roman Mostyka 2007-11-21 17:22:08 UTC
Build: NetBeans IDE 6.0 RC2 (Build 200711201000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
1. Create web application with "Visual Web JSF" framework.
2. Add Button component to the page.
3. Add second page.
4. Open PFE and create link between Button component on the first page and the second page.
5. Delete both pages from Projects view.
6. Choose in PFE "Faces Configuration Only".

Result: IllegalArgumentException arises.
Comment 14 Roman Mostyka 2007-11-21 17:22:13 UTC
Created attachment 53319 [details]
stacktrace
Comment 15 Exceptions Reporter 2007-11-27 00:38:11 UTC
THIS ISSUE HAS 5 MORE DUPLICATES
Comment 16 Tomas Danek 2007-12-05 14:33:10 UTC
Build: NetBeans IDE Dev (Build 200712040000)
VM: Java HotSpot(TM) Client VM, 1.6.0_01-b06
OS: Linux, 2.6.20-16-generic, i386

User Comments: 
just editing xml file
Comment 17 Tomas Danek 2007-12-05 14:33:14 UTC
Created attachment 53901 [details]
stacktrace
Comment 18 Lukas Hasik 2007-12-06 16:03:17 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows XP, 5.1, x86

User Comments: 
exception appeared when I copied a wsdl + xsd into new empty file created in IDE
Comment 19 Lukas Hasik 2007-12-06 16:03:20 UTC
Created attachment 53955 [details]
stacktrace
Comment 20 Lukas Hasik 2007-12-06 16:04:22 UTC
WOW, this issue has 46 duplicates see the URL link
Comment 21 Exceptions Reporter 2007-12-23 17:56:34 UTC
THIS ISSUE HAS 5 MORE DUPLICATES
Comment 22 Exceptions Reporter 2008-01-06 01:16:40 UTC
THIS ISSUE HAS 5 MORE DUPLICATES
Comment 23 Marek Fukala 2008-01-10 19:28:45 UTC
fixed, it was a stupid accidental regression from my performance commit from September 21. Oh man, let me know sooner
you have such issue next time :-)

Checking in DocumentModel.java;
/cvs/xml/tageditorsupport/src/org/netbeans/modules/editor/structure/api/DocumentModel.java,v  <--  DocumentModel.java
new revision: 1.44; previous revision: 1.43
done
Comment 24 Jiri Skrivanek 2008-01-11 09:24:02 UTC
Verified.
Comment 25 Samaresh Panda 2008-01-15 23:03:04 UTC
*** Issue 119563 has been marked as a duplicate of this issue. ***
Comment 26 pgebauer 2008-03-06 17:02:50 UTC
The fix has been ported into the release601_fixes branch.

Checking in DocumentModel.java;
/cvs/xml/tageditorsupport/src/org/netbeans/modules/editor/structure/api/Attic/DocumentModel.java,v  <--  DocumentModel.java
new revision: 1.43.8.1; previous revision: 1.43
done
Comment 27 Mikhail Matveev 2008-03-14 16:02:26 UTC
Cannot reproduce in 6.0.1 Patch2.
Comment 28 udhayakumar 2008-08-28 05:41:13 UTC
 Hi..

      When I Getting Netbeand IDE 6.0.1 started itself this error(error generated in parsing)coming.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo